Connected to "something" 8/10 (noob-trouble setting up)


#1

What is the problem?

Printer "connected" but not responding, octoprint gives me:

Send: N145 M105*39
Recv: Error:No Line Number with checksum, Last Line: 0

What did you already try to solve it?

Turned it off and on again. (didnt work)
messed around a bit, no result.
Made a new install on a fresh sd card, still no result.
used the google, too many informations, came here begging for some knowledge.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

i dont know what info to add so i'll go by it step by step.

I bought a Wanhao duplicator i3+ mk.2 recently and placed it out of my usb-cable-collection's reach, smart me. Instead of going the 1.99 stoneage gcode chisel way and slapping a 2m cable in it. I want to connect it to a raspberry pi 3b+ with the v2 camera (to see what i can already see when i squint a litte, but hey, dont judge me)

I downloaded the latest image from Github, flashed it with Etcher.

Did the Pi and octoprint setup and (almost) everything seems to work.

Wi-Fi works, camera works, connecting to printer with settings on auto, works like a charm.

Untill i want to actually make the printer do something.

Pressing any of the buttons on the control page doesnt work (they are not greyed out)
and on the Terminal page it spams:

Send: N145 M105*39
Recv: Error:No Line Number with checksum, Last Line: 0

When i try to connect to the printer it gives me:
Serial Port: /dev/tty/USB0

When i try this port, and go through all baudrates manually i cant connect to any.
AUTO AUTO connects to "something" withing seconds.

What am i connecting to? am i trying to send gcode to the keyboard?

I probably messed up somewhere so if any of you smart souls got a clue where i went wrong and want to win 5000 internet points (dont spend then all at once!) and a firm digital handshake, then please let me know.

octoprint.log (13.8 KB)
serial.log (148 Bytes)

NEW LOG:serial (1).log (14.8 KB)


#2

Hi!
Your serial.log is quite empty, because serial logging is not activated.
You can do this in Settings -> Serial Connection -> Common and there at the bottom.


#3

Thank you for your reply,

i have made a new serial log.


#4

Not sure what firmware you're running. You mention that it's a long cable; make sure that it has ferrite cores because in terms of electronics: long cable = AM radio antenna.

Either the problem is your serial cable or your firmware in this case. I'm guessing that it doesn't do line numbers + checksums. I think I'd turn that feature off to see if it works better.

~/.octoprint/config.yaml:

serial:
  alwaysSendChecksum: false