Connecting octoprint to Creality CR10S4 trips out the printer


#15

Alright, so that's attempting to define a hotend preset for 185 degrees for M0 and 240 degrees for M1. I'm just not seeing the maxtemp anywhere.

Actually, isn't that supposed to be S0 and S1 instead of M0 and M1?


#16

Yes I think these are the presets on the LCD for PLA and ABS. Possibly for retracting filament. Just trying to figure out if I can flash via octoprint. If I can get VNC going over ssh that should be possible.

So too many posts I must be a spammer!

Because at times with a local screen things can be controlled easier via a web ui than the god awful single control knob and tiny, crude screen. So I happen to have a spare 10inch touch screen that is designed to drive the Pi3b. I am also 30km away at times like now and if I can make Arduino ICE etc work remotely on the Pi3 I can do a lot more this far away.

=======
"ecv: okRecv: Error:Thermal Runaway, system stopped! Heater_ID: bedWARNING! Received an error from the printer's firmware, ignoring that as configured but you might want to investigate what happened here! Error: Thermal Runaway, system stopped! Heater_ID: bedSend: M27Send: M27Recv: SD printing byte 140021/464924Recv: okRecv: SD printing byte 140085/464924Recv: ok"

by the way this is the bed not the nozzle, but its running Ok at 65C

Ok flashed firmware to TH3d's version cant see any more errors and I can see the sd card now!


#17

To the best of my knowledge, VNC requires the Xorg (X-Windows) GUI to be installed on the host. I'm not sure why you'd need that to either the Raspberry or the controller board.

I think I would try something like avrdude.


#18

I think this comes down to the bed heater on the CR10S is too small and hence takes too long to heat, tripping the safety feature in marlin due to "no response". (I assume) this seems to be a known problem with this printer and only happens on initial heatup, once running no problems.


#19

So then it sounds like, for the Creality CR10S, preheat the bed then start the print.


#20

This may be a silly question, but is the RPi getting enough power? Some USB cables are woefully inadequate for an RPi, being only spec'ed to 0.5 amps and the RPi needs at least an amp, sometimes more than 2.


#21

I am having the similar issue with my cr10s. It has the same temp error message and it shuts down the printers monitor when it happens. prints fine without connecting with octoprint. im leading towards a firmware issue. thinking of flashing to a previous ver. or different.


#22

Try preheating the bed then start the print. It sounds like the heater is too small (takes too long) or the wiring's too thin or the driver's not pushing enough power or the voltage is too little... could be anything.


#23

Hi all. I'm new to all this. However I was getting the same blank/blue screen whenever I tried to connect my PI to my CR10S. And in the browser, I saw this:

Your printer's firmware reported an error. Due to that OctoPrint will disconnect. Reported error: "maxtemp" triggered, system stopped! Heater_ID: 0

After playing around, I changed the Baudrate form auto to 115200 and now I can connect. Sorry I can't help anymore but wanted to post in case it helped.
Thanks
Danny


#24

@dannykellett It feels like the room temperature could be a factor here. If the room was cold the first time, this might have been enough to have prevented the heater from working fast enough. Once you'd heated things up a bit (or the room temperature was different on another day) then you were able to heat up things within the timeout period.


#25

Hi
Thanks for replying. I read that. I tried waiting and manually turned the heat on using the dial. Then connected and the same thing happened. Also, my spare room is a box and with two PCs, it's always hot :slight_smile:

Thanks for replying though


#26

Ok coming back to this. It's doing it all the time now. Any ideas please?

Changing monitoring state from "Connecting" to "Operational"
Send: N0 M110 N0125
Recv: ok
Send: N1 M115
39
Recv: FIRMWARE_NAME:Marlin 1.1.0 From Archive SOURCE_CODE_URL:http:// ... PROTOCOL_VERSION:1.0 MACHINE_TYPE:www.cxsw3d.com EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000
Recv: ok
Send: M20
Recv: Begin file list
Recv: /CR-10E~1/HUBA3H~1.GCO
Recv: echo:enqueueing "M84 X Y Z E"
Recv: Error:MAXTEMP triggered, system stopped! Heater_ID: 0Changing monitoring state from "Operational" to "Error: MAXTEMP triggered, system stopped! Heater_ID: 0"Changing monitoring state from "Error: MAXTEMP triggered, system stopped! Heater_ID: 0" to "Offline (Error: MAXTEMP triggered, system stopped! Heater_ID: 0)"Connection closed, closing down monitor


#27

Just a hunch. Eject the SD card that's in the printer.

See also

and

which both were cases where a broken SD card in the printer caused "tripping out the printer" on listing the contents of said SD card (which is one of the things that happen when OctoPrint connects to a printer that signals that it has an SD card).


#28
/CR-10E~1/HUBA3H~1.GCO

@foosel Is it possible that Marlin really doesn't like Microsoft's attempts at shortening long file names? The ALLCAPS, the 8.3 naming and the tildes are a dead give-away to me.


#29

Hi,

I had this symptom until I flashed to TH3Ds firmware. I suspect the firmware on the S4 is faulty.


#30

Thank you so much foosel. That worked. Please let me know your paypal and I will buy you a coffee


#31

@OutsourcedGuru Nah, that is alright. My money would rather be on reading a corrupted file system causing a buffer overflow somewhere.

@dannykellett support.octoprint.org :wink:


#32

Done and thanks again


#33

Thanks @foosel. I had exactly the same issue with my stock CR-10S and simply popping out the card solved the hole issue!


#34

Exact same problem. Solved with removal of SD-card. Thank you @foosel!