Taz 6 makes continuous loud beep sound on connect


#1

When I try to connect to a Lulzbot Taz 6 the printer makes a loud continuous beep sound. If I switch the printer off and then 'on' after I click connect in octoprint, the sound stop and octoprint works fine after. I don't want to switch the printer off and on every-time I need to connect to the printer.

I grabbed the master branch of octoptrint and built it from source. I am running it on a laptop with ubuntu mate 18.04.


Connecting octoprint to Creality CR10S4 trips out the printer
#2

I know this does not help, but I am having the exact same problem.

I have corrected it by the same method although it did not always seem to clear just be cycling power to the TAZ6. I am using Octopi on a Raspberry Pi.

I thought the problem might be extruder related but I have had the problem on both the stock extruder and an aerostruder. I have also had the problem on more than 1 TAZ6. I have searched through LulzBot manuals and LulzBot forums and have not found out what the beeping means.


#3

I contacted Lulzbot support and they said it has to be an issue with octoprint.


#4

So could you please share the needed information?


#5

What do you mean by needed info?


#6

Those that have been asked for when you wrote the first post in this thread and you deleted...

grafik


#7

Attached the log files, I am using a Lulzbot Taz 6, with OctoPrint : 1.3.9 on Ubuntu Mate 18.04

octoprint.log (55.7 KB)
serial.log (148 Bytes)


#8

Thank you @jakkala_kalvik!

For it is an serial communication problem with your TAZ, please enable your serial logging as described in the file you send:
2018-11-17 22:03:30,375 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log


#9

Is the loud beep a signal that a long-duration command is running?

Maybe it's trying to tell you that your bed is heating up or similar.


#10

Attached the new logs with serial logging enabled.

octoprint (1).log (5.1 KB)
serial (1).log (14.3 KB)


#11

The sound is very loud and annoying, I doubt it's a signal. I tried to see it the sound stops after a while but It didn't after 15 mins and I gave up. Also the sound continues even if I disconnect octoprint. Once the sound starts, it does not stop.


#12
2018-11-20 00:22:39,722 - Recv: Begin file list
2018-11-20 00:22:39,861 - Recv: /DOCUME~1/MANUAL/SOURCE/MANUAL.GST 363
2018-11-20 00:22:40,906 - Recv: /PRODUC~1/LABELS/TAZ_60~1.GLA 624895
2018-11-20 00:22:40,910 - Recv: /PRODUC~1/LABELS/TAZ_60~2.GLA 624895
2018-11-20 00:22:40,912 - Recv: /PRODUC~1/LABELS/TAZ_60~3.GLA 624898
2018-11-20 00:22:40,912 - Recv: /PRODUC~1/LABELS/SERIAL~1.GLA 1741
2018-11-20 00:22:41,021 - Recv: /PRODUC~2/ELECTR~1/RAMBO/BOARD/ADAPTERS/RAMBOS~1/GERBERS/RAMBOS~1.GBL 30359
2018-11-20 00:22:41,025 - Recv: /PRODUC~2/ELECTR~1/RAMBO/BOARD/ADAPTERS/RAMBOS~1/GERBERS/RAMBOS~1.GBS 1166
2018-11-20 00:22:41,028 - Recv: /PRODUC~2/ELECTR~1/RAMBO/BOARD/ADAPTERS/RAMBOS~1/GERBERS/RAMBOS~1.GTL 30131
2018-11-20 00:22:41,029 - Recv: /PRODUC~2/ELECTR~1/RAMBO/BOARD/ADAPTERS/RAMBOS~1/GERBERS/RAMBOS~1.GTO 14810
2018-11-20 00:22:41,032 - Recv: /PRODUC~2/ELECTR~1/RAMBO/BOARD/ADAPTERS/RAMBOS~1/GERBERS/RAMBOS~1.GTS 1166
2018-11-20 00:22:41,340 - Recv: /PRODUC~2/JIGS/CONTRO~1/TAZ6_C~1.GCO 1008
2018-11-20 00:22:41,344 - Recv: /PRODUC~2/JIGS/CONTRO~1/TAZ6_C~2.GCO 1331
2018-11-20 00:22:41,345 - Recv: /PRODUC~2/JIGS/CONTRO~1/TAZ6_C~3.GCO 1389
2018-11-20 00:22:41,347 - Recv: /PRODUC~2/JIGS/CONTRO~1/TAZ6_C~4.GCO 3335
2018-11-20 00:22:42,384 - Recv: /P��>

Just a hunch, but try ejecting the SD card that's in your printer and see what happens then.


#13

That fixed it. Thanks.


#14

That means it was caused by some corruption on your SD card that made your firmware flip out. Nothing to do with OctoPrint but rather with some funny firmware behaviour in case of file system corruption on the SD.


#15

I have been following this thread since I have the same problem and this idea of removing the SD card from the printer (and then reconnecting) did work for me. I can say with pretty good confidence this was the problem because I have 2 identical configured TAZ6s and this problem was only occuring on one of them and it just so happened that I did have an SD card in that one. Normally I do not have SD cards installed in the printers but I do allow users to use SD cards in case of some other problem.

So just a few possible follows up if someone has the time:

  • Is there a real way we could see that was the problem from the terminal data? I am only asking so we can become better users/troubleshooters. I certainly appreciate the solution but knowing why will help us in the long term.

  • Is there a problem with the SD card that I should try and fix? We do have to use the SD cards to update printer firmware and unfortunately that is not that uncommon since we swap extruders sometimes.

Thanks though!


#16

I can only tell you what made me suggest to try to pull out the SD card in the first place, and that was the binary data garbage in the file listing:

2018-11-20 00:22:42,384 - Recv: /P��>

That doesn't look healthy. It's supposed to look like the lines before. And after that line the printer didn't continue to output anything on the serial and then (was) restarted. Hence my suggestion to remove the SD card and hence the source of the binary garbage.

Possibly. It certainly looks like file corruption, so I'd run a file system check on it and if that doesn't fix it replace it. If that STILL doesn't fix it it might be something between firmware and SD card that's acting up, but that's where I'd get in touch with the manufacturer instead of trying to debug myself.


#17

Oh, btw - can someone (maybe you, @jakkala_kalvik) maybe follow up on this with Lulzbot support and tell them it was NOT a problem with OctoPrint but rather requesting a file list from their firmware with what seems to be a corrupted SD in the printer's SD card slot? They might want to know that so they can look into it from their side. It certainly is the first time I've heard about printer firmware causing the printer to beep loudly in case of SD card issues.


#18

Thanks. I did notice the garbled text you mentioned and it makes sense now.

As for follow up with LulzBot, if @jakkala_kalvik has an open case with them, it would be best for him to give this feedback, but I also have reasonably good direct contact with LulzBot so I will also provide this feedback to them as well. I should actually see reps from them in person over the next few months. Clearly LulzBot is promoting Octoprint as a solution so they should do their best to work with Octoprint.