Control tab missing since upgrade to Python 3

Printer control tab seems to be missing after upgrade.

Under Python 2, there was a printer control tab that allowed me to control the axis of the printer and display the image from the Pi camera. This was nice because I could raise the z axis if I cancelled a job without going through the printer menus to do this. When I upgraded to Python 3, the printer control tab is gone, and there doesn't seem to be any equivalent. Is this a plug-in now, and where can I find it? Also, the control tab allowed me to see an image of the Pi camera. For the dashboard now, I can select to display the video, but I don't want to display the video all the time because of network traffic. Any help?

Thanks in advance.

Steve

Hello @Steverino

Any further information?
There was a template when you opened this thread that asked for some specific information. Sadly you deleted it.
The only things we know is that you upgraded to Python 3 and that you are missing the control tab.

I would think this is a common problem, which is why I didn’t include the logs. What else should I have included, which I can add to this thread?

It's not common. Upload octoprint.log and there might be something in it that can help us help you.

octoprint.log (261.8 KB)plugin_pluginmanager_console.log (76.1 KB) plugin_firmwareupdater_console.log (59.6 KB)

well first off I see an error related to Bed Level Visualizer possibly. To fix that and get it to load use the command below.

sudo apt install libatlas3-base

I don't think that would effect the control tab from being able to be loaded, but doesn't hurt to try and fixing that and see.

1 Like

The UI is not usually affected by the Python 3 upgrade, only the server. I suggest you try safe mode, as was suggested in the template, and also check the permissions your user has in OctoPrint. Not sure there's any other way the tab can disappear.

It's not a common problem, given several thousand people have upgraded over the last few months and no one has had this issue. And logs should always be included, whether you think they're relevant or not.

2 Likes

Sorry. I included the logs yesterday.

I have the same problem in safe mode.

Did the fix for the bed visualizer. Same issue.

Here is a screenshot of the Octoprint UI.

Make sure it's not just hidden in the overflow menu:

1 Like

Nope. Already checked that. The only things there are:
Gcode Viewer
STL Viewer

Have you checked config.yaml to see if it's disabled in the appearance section?

No. Where do I find config.yaml and how do I access it?

Never mind. I found it.

components:
disabled:
tab:
- temperature
- control
- gcodeviewer

How do I re enable these?

remove that line - control and save the file then restart octoprint.

That worked. I now have control back, along with temperature.

Thank you.

I wonder why that happened during the upgrade?

1 Like

It shouldn't have to be honest. Not sure how those got disabled in your config.

Also, please don't forget...

Did that. Thanks.

1 Like