Could not upload the file。

What is the problem?

When I upload gcode format files to octoprint or SD card, I will be prompted“Could not upload the file. Make sure that it is a readable, valid file with one of these extensions: .g, .gco, .gcode”.The error prompt is{"error":"The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application."}.But refresh the file list and find that it has been uploaded to octoprint. However, it cannot be uploaded to the SD card. After uploading to the SD card, an error is also prompted, and the file appears in the octoprint upload folder.

What did you already try to solve it?

I tried to reinstall octoprint;Upload files on IOS software;enter safe mode, but all of them failed to solve the problem

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle (82.3 KB)

Additional information about your setup

OctoPrint 1.7.2, marlin2.0,mks robin nano v1.2, windows, edge chorme version

Where is your OctoPrint server running? What hardware is it installed on?

There's a lot of errors in the log, from internet issues to lots of permissions issues. Seems like a non-standard install that we need more details about.

I use octo4a software to run octoprint on Android phones.

Have a look here:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.