Crazy printer with OctoPrint

What is the problem?

My printer is doing all kinds of crazy stuff. A lot of extra moves at the start of a run, then after each layer it is going back to the center, then back to where the print starts. When it runs the starting test on the left edge, it even prints it in the air.

What did you already try to solve it?

I have narrowed my problem down to OctoPrint. I took the same g-code file and connected my laptop to the printer, and printed from Pronterface. It came out perfect and zero issues. So I know it is something that OctoPrint s doing, I just dont know why or how to fix it.

Have you tried running in safe mode?


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Creality CR-10 Max, with new MicroSwiss Hot end and direct extruder.
Whatever the current version of octoprint is. It updates automatically.
I have been using Prusa for my slicer

I think you forgot this part :wink:

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Without logs we can't really tell what's going on

Also try it in safe mode to rule out plugin related problems.

Ok. I’ll try to do that Wednesday when I get home.

Sounds like some timelapse activity, is that enabled?

maybe Octolapse - timelapse doesn't do that.

So it did look like timelapse was on. And I was getting duplicate startup codes. 1st set was being output from my slicer and another by OctoPrint. I deleted the start and end codes in OctoPrint and disabled Timelapse. Worked perfect.
Thanks for the help everybody