CURA 4.5 dropping API key

Recently upgraded to CURA 4.5. Was running 4.4 and octoprint with no problems for awhile. Now 4.5 drops the api key every instance I run CURA. I have to reinstall the key each time I use CURA.

I have no problems from the Octoprint web interface, connects fine to printers. Shows CURA's API key no problem. Have tried deleting the key and generating new ones.

CURA displays 'octoprint fatal error' as well even though I am connected to the server and can print from CURA..

My Octoprint server is a RPi hardwired to the network. Running a BIBO2.

I have not heard of that happening before. Could you upload and post a link to your cura.log? It can be found through Help -> Show configuration folder.

Thanks FoV, here is my log: (305.7 KB)

Appreciate any help.

Thanks for the log.

In the configuration folder, there's a subfolder named "machine_instances". Could you send me the contents of that folder in a DM?

1 Like

I am having a similar issue on a multi instance Octolinux build w/ Cura 4.5. I was able to finagle it a bit by editing the Octoprint instance in cura, showing reverse proxy options, and entering the http credentials for the Octoprint instance.

Here are my log files if it helps:cura.log (2.4 MB)