Cura OctoPrint Connection plugin

For anyone having issues with the "API key not valid" on Cura 4.1 this worked for me. Add you server instance manually and check the box for "show reverse proxy options". Add in your user name and password used to connect to the OctoPrint server via the web interface and hopefully it should work. That did the trick for me anyway after trying everything else I could think of.

image

2 Likes

I just noticed that the OctoPrint Connection plugin has recently passed the 100.000 downloads milestone from the Cura Marketplace. It is the first plugin to do so, so that makes me proud.

:cake:

4 Likes

Many thanks for your plugin !

I have 2 printers, and 2 Octoprint servers, only 1 Cura of course ; is there a possibility to choose what printer to print to ?

Hello, and first of all congratulations on the great work @fieldOfView ! I've just discovered the Octoprint connection plugin and I'm having an issue which doesn't seem to be mentionned here yet : I am stuck in the API key checking process. Nothing happens... Any clue on how to fix that ?

I have 2 printers, and 2 Octoprint servers, only 1 Cura

The idea is that you add two printers in Cura, and connect each to a different instance of OctoPrint.

Are you sure the IP Address and port (5001) are correct? Normally the port is 5000.
Do you have a reverse proxy in place? Is it password protected? What version of OctoPrint do you use?

Thank you for your quick reply. Actually that makes a lot of sense, I never thought to do it like this :wink:

So I could just select what printer, slice, and send to the correct octoprint ?

So I could just select what printer, slice, and send to the correct octoprint ?

Yes.

Ultimaker have released a beta of Cura 4.2. Please help me test this version of the OctoPrint Connection plugin:
files.fieldofview.com/cura/OctoPrintPlugin-v6.0.0-2019-07-18T12_32_22Z.curapackage

Download the file and drop it onto a running Cura 4.2 application window. Then restart Cura.

1 Like

Thank you so much
I'll test it later this evening

Working here, thanks.

1 Like

I can print from Cura using version 4.2 and the package posted here with Octoprint 1.3.11.

I can however not see my webcam image in Cura. I can view it on the Octoprint web interface and when I use the URL to the stream that is also mentioned in the Cura log (192.168.0.87:80/webcam/?action=stream) as well as from 192.168.0.87:8080/. Is there any setting I need to change to be able to view the webcam in Cura?

I attached the log file in case it is of help to find out, what the problem might be.

cura.log (199.8 KB)

Working here and webcam image is also working. Thank you

There’s a checkbox in the Connect to OctoPrint dialog to enable the camera display.

I already have this checkbox activated. Could this be a firewall issue, or anything else that doesn't have anything to do with Cura or Octoprint?

Working with 4.2.1 for me

I'm having trouble getting this to work in Cura 4.2.1 for Creality Ender 3. I don't have a "Connect to OctoPrint" button in the manage printers dialog. I've tried uninstalling and re-installing the plugin and disabling/ enabling the printer. Any Ideas why the plugin doesn't seem to be working?

I was too with the version in the market place. I installed the version in the previous post from fieldOfView and it works fine.

Thanks I'll try that.

Right so I have downloaded latest version Cura 4.2.1 but octoprint is not working when I checked log it says:

"OctoPrintPlugin.__matchVersion [53]: This version of the plugin is not compatible with this version of Cura. Please check for an update"

Please look into it & Thanks for your work