Does OctoPrint 1.4.0 and later only run under Python 3 now? Did OctoPrint stop supporting Python 2?

No.

OctoPrint 1.4.0 also supports running under Python 3.7+ but it continues to also run just fine under Python 2.7 and will continue to do so for a while.

Please do not confuse "supports running under Python 3" with "no longer runs under Python 2". Both Python 2.7 and Python 3.7+ will work just fine.

2 Likes

BUT if you run OP under Python3, make sure that your installed plugins will also work with Python3!

1 Like