EMI / UART issues

What is the problem?

I know it's not related to Octoprint at all, but felt like asking the community in case someone had a similar issue, I wasn't able to find anything matching my case so far.
Almost 100% of the time when I turn off the light of the room where the printer sits, UART connection is interrupted and printing stops.

dmesg says:

[337002.158433] usb 1-1-port1: disabled by hub (EMI?), re-enabling...
[337002.160804] usb 1-1.1: USB disconnect, device number 23
[337002.162140] usb 1-1.1: failed to send control message: -19
[337002.165768] ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
[337002.166095] ch341 1-1.1:1.0: device disconnected

What did you already try to solve it?

Light used to be a "fluorescent tube light", that I recently switched for a LED equivalent, problem persists.
I used to have a non shielded USB cable, switched for a shielded one.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle


Additional information about your setup

Well just do a search you will find many.
Here is one that sounds pretty close.

It seems freezers and other compressor/inductive load types are almost always the issue.

Small UPS. Is the easy solution. Also make sure you have a good shielded USB Cable and blocking the power positive on your cable is also recommended. Search "Power block" or 5V. And you will get lots of that. Try to use a solution that does not break your cable shield loop.

Sounds like it's on the same circuit as the light
Either a noisy spike affecting the motherboard of the printer, or the spike affecting the odroid

You can buy an in line mains filters which will help.

Wherever you have large switching inductive loads around you can get spikes on the mains.

Many thanks for all your answers.

I already have a "power block" in place, and tried to hook the printer and Odroid to my UPS and it worked. Not at the same location though but on the same electrical circuit.

I'll try to find a cheap UPS and hope it will definitely fix the problem.

Thank you!

1 Like

I had a similar issue with a soldering iron. I fixed it by using a good USB cable, and putting a clip-on ferrite supressor at each end.

I ended up buying an APC BVX700LI, the USB cable is double-shielded with ferrite, the printer is in a creality enclosure and I still have the same problem :cry:

Are you sure you used the battery backup outlets for your printer and pi? There are only 2 on that UPS.

An UPS does not help much if there are high power devices (*) without proper EMI suppression and filtering close to the printer setup.

In this case direct EMI radiation will corrupt the proper working of the printer electronics.


  • washing machines
  • dryers
  • fridges
  • ACs
  • drill presses
  • lathes
  • mills
  • ...