Ender 3 - Bed Visualizer ignores limit switches

What is the problem?

I just upgraded my Ender 3 mainboard to V4.2.7, and when I went to test it out I used the bed visualizer, but as it moved it ignored the limit switches so it made horrible noises and made no progress.

What did you already try to solve it?

Haven't been able to find many solutions at all. I tried plugging in the pi after the printer was running as suggested by someone else, but that was ineffective

Have you tried running in safe mode and if so did it solve the issue?

Not yet

I guess you're using a bltouch?
Make sure you flashed a firmware with bltouch enabled.
run G28 to home the printer then run G29
I don't know how your firmware is configured so you could start with a 5x5 linear grid --> G29 P5

now the mesh data should be ready to be visualized by the Bed Visualizer

Everything works fine outside of octoprint, so the firmware on the printer isn't the issue

If your bltouch is working just start with the G28 part :slight_smile:

This is what's happening:

and what happens when you run the G28 and G29 commands in the terminal?

The only success I've seen with this new mainboard is not using octoprint, which really disappoints me

Meh not sure why G28 isn't working :confused:
it's a basic command

just wait some time maybe somebody else got an idea

Try taking the SD card out. Don't ask why, but this has definitely been the solution to this problem I've seen before.

1 Like

There isn't one in there

Let's back up a bit. What are you using in your gcode commands for updating the mesh data?

Edit: Just saw this happens with just G28, so definitely not a plugin problem. What if you use G28 X Y?

That did work, no issues for only X Y

I read earlier that it may work if I turn on the printer first, then plug in the pi and run it. I tried it now and it worked, however, I'd like a more permanent solution in case I forget to set it up in the right order

There were changes I had to make so I updated the firmware, and the issue has returned. I'm not sure what "fixed" it before

What is the problem?

Working with my printer alone is fine, but when I try to control my printer through Octoprint, the limit switches just don't work, including my Bltouch. I can self test it and everything, but when homing z axis, it just dies or something

What did you already try to solve it?

Someone said try turning on the printer, then plugging in the pi, then boot up octoprint, specifically in that order and it should work. It didn't. Not much else I had to try.

Have you tried running in safe mode and if so did it solve the issue?


Additional information about your setup

This issue began recently, when I just installed the new Creality V4.2.7 mainboard, and updated the firmware.

I merged your new post with your old post since it's the same issue.

Did you build the firmware yourself?

No, I downloaded the firmware Teaching Tech modified, and made edits of my own

alright let's try another thing:

Insert an SD card into your printer, rstart it and try again

Okay so I started the printer with an SD card inside, then plugged the pi into the printer, turned on octoprint, and now it is working;

I don't know if it will stay working now, or if it has to be done under these conditions