Ender-3 Neo Screen blocked when connect usb data from RPi to printer

Hi all!

I'm experiencing a very strange problem with my Ender-3 Neo screen.

I installed a Raspberry Pi 2B with Octoprint 1.8.6 + SimpliPrint 4.0.5.
RPi is powered by Ender power supply (24v) with a LM2596 step down converter regulated to 5v and connected to GPIO ports 2 (5v) and 6 (GND).

I connect USB data cable from RPi to printer and everything works fine, but the screen turns blocked and no refresh data anymore.

If I unplug USB data from RPi to printer, the screen is operative again.
If I unplug power from Ender power supply and I feed voltage from RPI usb port, and then I connect USB-Data cable to the printer, everything works fine and the screen works propertly.

So, it seems that the problem is due to the power supplied by GPIO ports...

I tried to connect from other 5v supply (power bank) directly to GPIO ports, and I have the same problem, hence the problem is not caused by LM2596 converter.

I tried with a spare RPI 2B and a RPI 3B with the same result...

Any ideas?

Screen blocked after USB-data connection:


I think you should try to isolate the 5v that is powering your Pi from your ender board. Use the tape method as a quick test. If solved the issue I would suggest a more fool proof method of isolation,

1 Like