Ender 3V2 extruder quits mid-print

I have an Ender 3V2 that is about 2 years old. It has periodically been plagued with spurts of "extruder quits mid-print" while X,Y,Z move normally. If I pause, and fiddle with the "EXTRUDE" and "RETRACT" button sometimes it cures the problem for a while. The extruder motor stops turning and the tension nis a minimum without gear slipping. After stopping print, the extruder works fine with NO hangups until mid-print on the next session. The filament over the years has changed, but not the problem. Right now it has been using PLAMAX from Amazon which works wonderfully. Also some PETG.
I've tried various temp settings, various print speeds, no retraction, various infills, various quality settings, various nozzle sizes, various flow rates, various fan settings.
Running Octoprint V1.10.2 and Cura 5.7.1 using a RPi Zero 2W for remote Octoprint connected to network.
Over the last 2 years various mods have been made to the printer with no improvement in "extruder quits including:
changed stepper motor
changed stepper motor cable
changed to Swiss direct drive
changed and tested all fans
added improved parts cooling ducting
changed from 4.2.2 motherboard to 4.2.7
changed hot end heater and sensor
upgraded bowden tube to high temp
ALWAYS check for excessive drag on filament draw from spool
changed motherboard to BigTreeTech SKR mini E3 V3
changed to BigTreeTech 3.5" TFT
nozzle changing and rest up of hot end doesn't help
various filament trials doesn't solve intermittent problem

This printer prints fine when the extruder doesn't quit.

I can extrude and retract like crazy using manual controls, no clogs.
Printer never quits during mid-print, just the extruder.

Put a "FLAG" on the extruder tip to observe motor operation with Octoprint camera
X, Y, and Z never quit.
I thought for sure the BTT SKR mini would solve the problem (thinking it was a weak or overheated Ender Extruder driver), but it didn't.

Just noticed a "Recv: Not SD printing" message on terminal... don't know if it is related
"Recv: Not SD printing
Recv: ok
Send: N11033 M106 S147.9114
Recv: M106 P0 S147
Recv: ok
Send: N11034 G1 F3600 X73.778 Y72.041 E653.63153
Recv: Not SD printing"

I will try the "Safe Mode" once I figure out where and what and how the "Safe Mode" works

Hello @john_procida !

Why do first-timers think it is cool to delete the template?

Please attach the systeminfo bundle to your next post.

No, in no way.

Can you print from SD one of the prints that fails without Octoprint?

"Why do first-timers think it is cool to delete the template?"

Be nice... Why not just constructively tell me what I did wrong. I tried to be very explicit.

wow you already tried so many things :open_mouth:
this will be hard to trouble shoot

Is the stepper still energized when this happens? (can you turn the gear or does it "block")

Carefully watching a print I thought I noticed a quick spark or instantaneous glowing wire at the stepper connection. Knowing that you definitely do not want intermittent connections on those large loads, I shut down the printer and from Amazon I overnight ordered a new set of cables. These cables are branded with "Creativity" in the title and they were mis-wired and mis-labelled causing a delay in repairs.

PLEASE, if you get new cables do check them wire by wire for correct connections and that the labels are correct. These cables came in with a "Y" cable, a "Z" cable and what looked like two "X" or "E" cables. Both of the "X" or "E" cables were marked with the "X" label at one end and the "E" label at the other end. Plus, to be used as an extruder (E) cable, both cables had the 4 pin connector end wire backwards. After carefully re-labeling the cable and re-wiring the 4-pin end the new cable was installed and the printer now works great again. Now it just needs to be retuned to accommodate all of the new parts thrown at the problem.
There is one curiosity that I have to figure out... The new BigTreeTech (controller and TFT) seems like it will no longer let me print from the SD card and the TFT has a running banner saying "the TFT is in listening mode"?? Any clues?

I am making a YouTube video on unboxing, checking and repairing the new cable set and it will be on my "jeneralab" channel shortly.

glad you found the issue and were also smart enough to not just pull the stepper cable. I did it once an had a big arc - wasn't my brightest moment...

try this:

go to "Connection" menu and press on the new icon (on bottom left) to switch to "OFF". The listening mode will be deactivated.


Worked like a charm... thanks for the info on "the listening mode".
Printer printing really well now. Just finished printing the Thingiverse case for the BigTreeTech TFT V3 and it fits like a glove.

1 Like