Error updating Pi Support Plugin

What is the problem?

When I tried to update the Pi Support Plugin it popped up a window to indicate the update failed.
I restarted OctoPrint in Safe Mode however the version for Pi Support shows the latest version now.
I'm not sure what the error was for since it seems to have updated?

What did you already try to solve it?

Rebooted to Safe Mode but could not reproduce the issue. The version showed the update happened.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (15.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.7.3, OctoPi 0.18, Printer Taz6, Browser Chrome in Windows 10.

Looks relevant:

Guess I will wait for 1.8.0

Why wait? Run the update, and when it fails, copy the command line from the beginning of the output. Open a terminal and connect to the pi using the same user that runs Octoprint, and paste in the terminal and it'll work.

For me, the command was:

/home/pi/oprint/bin/python3 -m pip --disable-pip-version-check install --no-cache-dir

and that worked. Charlie Powell referenced a new progress bar that broke things - so when I ran it manually, the progress bar displayed to the terminal and the update worked fine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.