Extruder temperature Wrong vs Cura GCODE

What is the problem?


I have an Ender Pro Direct BLTOUCH drive with SKR 2 Mini card latest Bigtreetech firmware

I have a problem since the last update, I have the temperature of the extruder which is not correct.
For example I set it to 210 in CURA and when I run the print it is at 260 in Octoprint

Thanks for your help

What did you already try to solve it?

Upade Firmware SKR et TFT35 E3 v3.0

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.69 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 3971153920
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: true
octoprint.version: 1.7.0
printer.firmware: Marlin bugfix-2.0.x (Jun 9 2021 15:03:14)
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Firmware SKR 2 Mini : firmware-bltouch-for-z-homing.bin

update Marlin to

Hello @rodolphe_tordo !

Have you seen this:

Also see this:

here is
octoprint-systeminfo-20211101191126.zip (119.6 KB)

I haven't seen the post OctoPrint sets my nozzle temperature/nozzle offset too high

I finish my print and do a test.

thank you so much

I try this OctoPrint sets my nozzle temperature/nozzle offset too high
But the problem persists

Can you please share a tiny mode gcode file.
Also please enable the serial.log (OctoPrint Settings -> Serial Communication -> Serial Logging) and after a print (attempt) please share that log too.

Since running in safe mode solved the problem, what you now need to do is disable or re-enable the plugins a few at a time and testing to see when the problem re-occurs, then you know which plugin is causing the issue.

Good evening,

I did a fresh install on a new RPI 4, my old RPI 2 was suffering :face_with_head_bandage:

I followed your recommendations. :innocent:

I installed the plugins one by one and indeed it is the Filament Manager plugin that had the problem, so I reset it and everything is ok for the moment

Thank you very much for your help and this great software that is Octoprint :slight_smile: :partying_face: :sunglasses: :cowboy_hat_face:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.