File setting selections not sticking after re-boot

What is the problem?

When I make a change to File Settings, then reboot Octoprint, it’s just goes back to default. i.e. Sort by name (ascending)

What did you already try to solve it?

googled, searched forum

Have you tried running in safe mode?

no

Did running in safe mode solve the problem?

n/a

Systeminfo Bundle

octoprint-systeminfo-20221014125147.zip (34.1 KB)

Additional information about your setup

OctoPrint version 1.8.4, OctoPi version 0.18.0, printer Ender 3 v2, firmware jyers 2.01, browser Edge, operating system Win 11/Win 10

Screenshot 2022-10-13 072620

Hello @Birdtrd !

You may try this plugin :

I had the same problem and there is/was a post somewhere on the forum about NOT deleting session cookies for Octoprint.
Sorry can't remember all the details or how I found (search terms) that post, but that worked for me.

Correction, did some digging and found it in this this one around post #13
< 894709>

1 Like

Thank you! the plugin fixed the problem. Much appreciated!

1 Like

Well, I spoke too soon. It initially stayed selected thru a reboot of both Octopi and the Ender 3, even checked it from and different PC and browser.
I hopped back on several minutes later and settings were back to default. I'll try saving cookies for the Octopi url specifically.

These settings are saved in your browser's local storage, rather than on the server configuration. They aren't cookies, but usually cookie-related settings in browsers also impact the local storage and sometimes these settings can't be persisted. Perhaps they persist until you close the tab or browser session, rather than when the server restarts.

Thanks for this info. I added octopi.local as an exception and the file settings now stick when the browser is closed and re-opened. Edge and Chrome both required the cookie exception, however Firefox and Palemoon worked out of the gate, no exceptions needed. Thanks :yum: