Flashforge creator pro 2 - setup

Hello

Has anyone been successful setting up a FF Creator pro 2 in Octo?

I have tried the 2 plugins related to FF printers with no success

Help would be appreciated

regards

Some logs would help us :wink:

Sorry. I have no idea what that means.

I cannot event get the printer to connect!

  1. Click the word logs
  2. Learn what it means

If you open the terminal tab, what does it say? Guarantee there is more than nothing. Copy and paste it's output here.

@PrintedWeezl can I take over and get you anything you need? I have a Creator Pro 2 that Octoprint can't seem to connect to. Nothing shows up in serial. I have the GPX plugin installed.

All that's in Terminal when I click Connect:

Performing autodetection with 0 port/baudrate candidates: 
Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."
Changing monitoring state from "Error: No more candidates to test, and no working port/baudrate combination detected." to "Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)"

Looks like the Raspberry Pi sees the printer:

[    2.064582] usb 1-1.1: new full-speed USB device number 3 using xhci_hcd
[    2.204363] usb 1-1.1: New USB device found, idVendor=2b71, idProduct=000e, bcdDevice= 2.00
[    2.204407] usb 1-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    2.204442] usb 1-1.1: Product: FlashForge Creator Pro 2 3D Printer
[    2.204472] usb 1-1.1: Manufacturer: Flashforge
[    2.204540] usb 1-1.1: SerialNumber: 00000000050C

Other logs attached. octo.zip (343.8 KB)

Yep that's much better :wink:
Afaik the GPX plugin doesn't work with the auto detect option - so you have to select a port.

If that's the full dmesg output then the printer wasn't detected as a serial device.
I'm not quite sure what to do about that.. Maybe there is some setting in the display menu that changes the usb behavior?

There are some other Flashforge printers which don't appear as serial device and there is a plugin for them

But according to its compatibility list you should use GPX plugin.

Printer Compatibility

Shows current state of printer Compatibility for core OctoPrint functionality and will be updated as users provide feedback.

Printer Upload File to SD Card Control Movement and Temperature Print Directly From OctoPrint
Adventurer 3 No (no USB port) No (no USB port) No (no USB port)
Adventurer 3C No (no USB port) No (no USB port) No (no USB port)
Adventurer 3 Lite No (no USB port) No (no USB port) No (no USB port)
Creator 3 No (no USB port) No (no USB port) No (no USB port)
Creator Max ? ? ?
Creator Pro No (Use GPX plugin) No (Use GPX plugin) No (Use GPX plugin)
Creator Pro 2 No (Use GPX plugin) No (Use GPX plugin) No (Use GPX plugin)
Dreamer Yes ? ?
Dreamer NX Yes ? ?
Finder v1 Yes Yes Yes
Finder v2* Yes Temp - Yes, Movement - ? ?
Explorer Yes ? ?
Guider Yes ? ?
Guider II* Yes Temp - Yes, Movement - ? ?
Guider II S* Yes Temp - Yes, Movement - ? ?
Inventor Yes ? ?
Inventor II Yes ? ?
Dremel 3D20 Yes ? ?
Dremel 3D40** ? ? ?
Dremel 3D45** ? ? ?
PowerSpec Ultra 3d Yes Yes Yes

Hi

Any help would be good. I've tried a few things. I tried setting up a custom profile based on creator pro1 but still havnt got it to work.

It would be good to find a solution!

OK, tried that Flashforge plugin and got an "unknown device, port 1:3" in the serial port drop down. I set baud rate to 115200 and it tries to connect, but then disconnects immediately.

Changing monitoring state from "Offline" to "Opening serial connection"
Changing monitoring state from "Opening serial connection" to "Error: Connection error, see Terminal tab"
Changing monitoring state from "Error: Connection error, see Terminal tab" to "Offline (Error: Connection error, see Terminal tab)"
Unexpected error while connecting to serial port unknown device, port:1:3, baudrate 115200 from hook GPX: FileNotFoundError: '[Errno 2] No such file or directory: 'unknown device, port:1:3'' @ comm.py:_open_serial:3670

Here's some new logs to see if you can tell anything else that might help. octo.zip (45.5 KB)

I’ve got it working, but I sill need to tweak the settings a little, as I’ve had a few failed prints. I’ve put some instructions together for you here. The problem you’re seeing is because you need to SSH on and allow some permissions, then you should be good.

Rich

3 Likes

Your the man! @rswio

Take it you're running octopi on rasbian and not directly flashed onto the card otherwise u wouldnt be able to run putty right?

SSH is enabled in the OctoPi images by default :slight_smile:

No, as @PrintedWeezl said, SSH is enable by default and I put the default username and password in the instructions for you too :slight_smile:

Good luck.

Thank you so much! I actually had added that rule, but to a different file. did it you way and boom, able to connect. will try some prints shortly.

You're welcome, and good luck. I've found that disabling the below helps prevent the print failures:


I've updated the article now to match :slight_smile:

hi @rswwio thanks so much for this. i have trawled the internet so hard and many have tried and failed. i am going to have a go at setting it up today. i am an absolute novice, but looks straight forward. i have never used putty before tho.
slightly on a tangent but what slicer do you use with octoprint?

thanks again

You're welcome. Putty is straight forward, so don't worry.

I just use FlashPrint at the moment, but I am currently looking for something else. I have noticed that dual prints via OctoPrint do not work. The extruders both heat up, but only one prints. Could be a setting, but I haven't found it yet. So I still use the SD card for dual prints.

Good luck.

hello,
@rswwio
...sorry to be annoying. I have got to the part where i am getting the error message on the home screen. just before you use Putty i am using a windows computer tho not linux this wont work for me will it?

I have downloaded putty anyway on MS. I cant login tho...i put the ip of the octoprint in. put my login in name and press enter. then i cant type a password? any ideas?

i am using rasberry pi 3 with octoprint flashed directly onto sd
i am using windows 10 and ip address to access it

thanks

If you just concentrate on the below highlighed items, you connect to the Pi first, from your Windows machine, and then you authenicate in the terminal windows after you are connected:
image
After you're connected the username and password are: pi / raspberry

hi

this part is fine.opens the terminal window as it should. my username and password have been changed.

once the terminal opens i type my username and press enter
it then asks for password but wont let me type

The username you use on OctoPrint is not the one to use in SSH. The default SSH credentials are:

Username: pi
Password: raspberry

Setting up/chaning a user in OctoPrint does not affect the Pi's user credentials.