GCODE viewer craziness


#1

What is the problem?
Load a GCODE file and start print. The GCODE viewer runs faster than the print, even with everything for printing set to 100% feed rate. it continually gets further ahead of the print. By the end of a 40 layer object, it finishes about 10 layers before the print. In addition, as the viewer is running, it will occasionally reverse itself, and "erase" what it shows was just done as if it was printing with an eraser, then stop and go forward again. This is doing it on not only newly sliced objects, but on GCODE files I had printed in the past without issues. It started suddenly without any changes made to octoprint or Firmware

What did you already try to solve it?
Updated Raspbian, Updated OctoPrint to the latest version, Started octoprint in safe mode, reinstalled raspbian and octoprint on a fresh microSD card.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
OctoPrint 1.3.10 on Raspbian Stretch Nov. 2018 release, Anet A8 with Marlin 1.1.9


#2

Hi @5ft24!
The GCODE position displayed is that one, that just is sent to the printer.
The printer has a buffer of a certain size. Depending of the complexity of what is printed, it takes a time to work down this buffer.

Also note this:
grafik


#3

I've been using Octoprint for a year, same printer, it's had Marlin 1.1.9 since it was released. It has just been the last month or so it has started doing this. That is why I tried a fresh reload of Raspbian and Octoprint, and GCODE files that were sliced and saved from months and months ago that didn't have the issue when printed previously, to rule out any issues with Cura as well. The show approx. Print head position. Just puts a dot where the print head would be. It doesn't change anything else in the Gcode viewer. I have tried multiple computers and multiple browsers, including Safari on my iPad, and all have the same result


#4

Did you set the option "synchronisize job"?
May bee this is the reason.


#5

Yes. As I said I have been using it without issue for a year. If that box is unchecked, the gcode viewer display never changes until you move one of the sliders


#6

Here is a picture of the Octoprint screen, and a picture of the printers display showing where it is really at:


#7

I get exactly the same with my printer. This is a new behaviour. Everythin was working fine a few builds ago.