Geeetech A20M only uses one Tool for dual extrusion print

What is the problem?
When I slice a dual extrusion print and send it to Octoprint it only uses one of the tools instead of both of them. It varies which tool is used. When the same gcode is printed from the SD card it runs successfully.

What did you already try to solve it?
Tried making sure the gcode was generated correctly.
Confirmed with a fellow octoprint user that he could print my gcode with a fresh install of octoprint with no plugins.
Successfully printed my Gcode one time in safe mode. After this I turned off all 3rd party plugins and it printed the part with one extruder as it had done before. put octoprint back in safe mode and it only used one extruder again.
Verified gcode was set to use 2 tools in octoprint
Printed Gcode from SD card with printer screen sans octoprint successfully.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Latest version of octopi/octoprint set up less than a month ago
This entire print printed with T1, even thought it was supposed to start with T0
Print was done in safe mode.

Attached logs, terminal output and gcode.Logs.zip (37.0 KB)

Did you configure 2 extruders in your printer profile?
This might help you

Thanks for the reply. I did do this. I even tried unchecking the shared nozzle box and setting a 0 offset. It is like it just uses whatever extruder the printer used last for the whole thing and doesn't swap even thought the gcode says to swap and it shows the command in the terminal window.

I am having the same issue. I have been using the A20M for mostly single color prints, and just recently tried a dual color print from the OctoPi (Did a few directly from the SD card early on). In cura it shows that dual extruders are setup, but during the print, only one is used.

I also made sure my printer profile was set to 2 extruders.

I think I may have partially figured it out. It looks like before a dual color print is started you have to make sure the mix is set to 100% of the first extruder used. At least it worked this time that way.

Thanks for the quick feedback. That is how mine was setup. But I may try switching it to see what would happen if the other extruder is set to 100% to begin with. At least that will tell me if switches to the correct one at the start.

I see it as more of a workaround than a solutions, but it seems to have worked this time. I may try the same model again and change the extruders in octoprint to see if it still works properly after this print is done.

Just an FYI, I did move the file to an SD card and it did print 2 colors. So I at least know now that it is something to do with the octprint settings. I will keep you updated.

I have been having the same issues with Octoprint. I have it set up with the profile with 2 extruders but looking at the terminal while printing during an extruder switch it is showing:

"Not queuing T1, that tool doesn't exist according to the printer profile or was reported as invalid by the firmware"

This led me down to reading the options in the firmware. The A20m/A10m and other printers of this type use mixing extruders where the firmware only sees 1 available extruder vs a true dual extruder setup. I gotten it to work by inserting a M163 command and controlling the ratio of the extruder motors.

for Extruder 1:

M163 S0 P1
M163 S1 P0

S: extruder motor
P: ratio of the motor mixing (adds up to 1)

Can we assume that this is in your OctoPrint -> Settings -> Gcode -> "Before print starts" code?

No.

Actually I insert that in my slicer setting prior to each color change.

So in cura it would be for the start sequence for each extruder.

For extruder 2 you would invert the settings
M163 S0 P0
M163 S1 P1

2 Likes

I am seeing this problem too. I just updated octoprint and tried to print a dual-color gcode that printed fine before, but now it never switches extruders. Current octoprint version is Version 1.3.12. I'm not sure what the previous version was.

Hello. I am doing final testing/setup for my new to me A10T, first multi color printer.
I have experience with Octoprint from my other printer setups.
I am wondering if there are still issues with Octoprint and the multi extruder single nozzle printer?
I am using Simplify3D and not sure if these modified settings would be better set in the slicer start sequence or in my Octoprint GCode settings (start sequence).
And if there is a new method of resolving the issues please let me know.
Thanks in advance.

It is the Octoprint/plugins that it is affecting the virtual extruder's functionalities.
I stroggled for days until a member in the forum advised this fact.
printing directely from the SD or USB via ponterface or repetier works correctly except via Octoprint!!

somehow Octoprint is removing or ingnoring the virtual extruders

OctoPrint will not send tool selection commands to the printer of which it doesn't know the printer will be able to understand them since there are firmwares out there that will crash when getting sent a tool change command without a way to actually run a tool change.

So make sure to actually configure your number of (virtual) extruders and if needed check shared nozzle in your printer profile and then OctoPrint will send your tool change commands just fine with the profile actually selected.

If that doesn't fix it, we'll need logs (both octoprint.log and serial.log which you'll need to enable first).

Thanks a lot for your info.
I just tested out and yes it is working.
I have to consider ALL virtual extruder as a physical extruder.
In my case I have set in my S3D slicer 6 extruders in total ( 3 physical and 3 virtual) and have updated my Octoprint from 3 to 6 and Now it is working.
Appreciated your info!!!!!!

So I need to setup the physical extruders and the virtual oin the startup script for S3D in order for it to see any virtual tool?

Hey @EXTRUD3D

I have a Geeetech a20m too and I have the same problem.

I have a gcode with dual extrusion, the gcode works fine from the SD card, but when I try to print from octoprint it only use one of the tools

I have checked "shared nozzle" and the problem persist

Could you please tell me your octopi print profile?

I'm using:

Print bed & build volume

Form Factor: Rectangular
Origin: Lower Left
Heated Bed: Checked
Heated Chamber: Unchecked
Width: 250
Depth: 250
Height: 250

Axes

x: 6000
y: 6000
z: 200
e: 300

Hontend & Extruder

Nozzle Diamer: 0.4
Number of Extruders: 2
Shared nozzle: Checked

I'm not sure that my information is ok. Thank you in advance

I also have an A20M and i have the exact same problem and i havent found a fix for it yet

You need to set as MANY extruder as you have set in your slicer: eg you set 5 total extruder for mixing them in Octo you need to set 5 instead of 2