Getting a touchscreen to work on OctoPi 0.15.0 running on an RPi3+


#1

Hi,
Totally new to forums and Octopi/print. When and bout the Pi3+ and the Pi touch screen. The 0.15 build worked but the desktop doesn't seem to.

I've run the set up script and it walks me though the option to start the desktop on boot and then to reboot. Unfortunately on a reebot there is no desktop just the same cli interface.

Is this something i' not doing right


OctoPrint, OctoPi and the Raspberry Pi 3+
#2

Let's see... it took me a fair amount of time to get the Desktop installed and working on a TFT screen.

Not sure if it's dated but this video suggests that it is a talk-through on setting things up for a touchscreen. Here is the accompanying blog post.

I note that recently the touchscreen calibration program is no longer working correctly as of some recent Raspbian O/S version like Stretch. So if you're having difficulty getting your touchscreen to accurately work then it's not necessarily what you're doing.


There's another thread on here which contains information.


#3

What size touch screen ?

I've got a 7" here that seemed to work right out of the box, and a 3.5" that took a bit of playing with

And I just downloaded the newest nightly, and installed it, and noticed that there are TWO DIFFERENT desktops

There's the one that you see an option for when you login, and a different one that you get in raspi-config

I just tried the one in raspi, and while it did give me a gui logon screen, nothing I tried would get me logged in. Then I tried the one you see when you first log into the cli, and that worked

What size screen are you using ? The 7" I tried worked first time, I had to remotely install an onscreen keyboard first, but it worked. Except, now I can't login without a bluetooth keyboard to type the username and password

As for the 3.5", well, it's working, but it's not calibrated properly. Gave me a desktop tho. Also can't log into it without a bt keyboard, and even when I do, I can't use it cuz it won't touch where I touch it. Obviously I need to find a different calibration technique, or maybe different drivers


#4

The previously-working touchscreen calibration tool broke in Stretch, the latest version of Raspbian. Still not sure how to get that to be happy.


#5

Ok, I got it (mostly) working on the 3.5" screen

The calibration is good, but, I can't seem to double click on the icon I made on the desktop to run the matchbox keyboard program :frowning:

it works when I double click it with the bluetooth mouse tho, so, I guess I'm still missing something

So, this is a nightly build of Octopi stretch lite 0.15.1

Here's the driver set I used...

Not sure what's lacking about the double click part, but, the calibration is right on...

OH ! Wait !

When I use the stylus, the double click works !

(Must be something about my fat fingers)


#6

Oh, that looks nice. I like the onscreen keyboard.


#7

Heh, yeah, quaint, ain't it ?

It's especially nice if you happen to like typing with a set of chopsticks

Reminds me of those digital watches all those years ago with a calculator built into them where you needed to press the buttons with a pencil


#8

Ok, update and in short I'm a fool...

I had 3 issues:

  1. Not enough power, it wasn't voltage it was current. I've got a 5.0v brick style PSU that can deliver 8amps and that worked and got rid of the lightening symbol. Not sure how much on an issue this would have been but its gone now.

  2. I wasn't connected to the network. I had updated the supplicants file from the touchscreen cli using nano but... and this is where i was the fool, i didn't remove the #

  3. when I was running the desktop script it wasn't actually downloading anything. The script ran and to my inexperienced eye looked like it completed. Once wireless was up and the script was run the difference was obvious!

Now I have the desktop.

Unfortunately I also realise that not what I want. I think I want the boot to browser and TouchUI. I followed the instructions and it didn't work but i'm assuming thats because I installed the desktop first. I've just re-imaged and will try getting TouchUI working without the desktop


#9

Okay, now I'm the one that's confused

You want to boot to browser, not desktop ?

But, the browser runs ON the desktop

Obviously I'm not understanding what you're saying

Say it again, but, this time, type slower, so even id10t's like me can understand it