Getting OctoPrint Working

I am having trouble getting Octopi working for the first time. Using Version 1.7 on a Windows machine. Everything looks OK but Octopi cannot seem to get handshake from Printer after 3 tries...I have extended the timeouts etc no luck. Changed baud rates up and down and still no luck. Any ideas?

There is a bit of a nomenclature issue here. OctoPi is the name of the Raspberry Pi OS which includes OctoPrint, "the snappy web interface for your 3D printer".

You can install OctoPrint on a Windows machine and I believe there is even a guide to help.

The next issue is the version... OctoPrint's current version is 1.9.3 which has had many updates and bug fixes since 1.7. If you are having problems, most of the experts in this forum would prefer to eliminate any problems already fixed in 1.9.3 so they can concentrate on any problems you are having installing the current version.

It would also help us help you if you included as much detail as you can about your environment including the printer model, firmware, etc. as well as what version of Windows, etc.

1 Like

The reason why it installed OctoPrint 1.7 and not the latest version is because you're still on Python 2.
OctoPrint 1.8 and upwards require Python 3.

I think it would be the best to either upgrade OctoPrint or start over now, when you haven't done much.

If you want to start over, I would recommend to install it via @jneilliii s Windows installer: GitHub - jneilliii/OctoPrint-WindowsInstaller

OK - So today I did a complete erase and re-imaging of the Pi/Octoprint SD card. It is now loaded with version 1.9.3. Octoprint loads, connects to Internet and I can even see my USB camera feed from my remote workstation. Still, the system will not connect to my 3D printer with the identical (Handshaking) errors mentioned earlier. My 3D Printer is a generic (no name) printer which is software/feature compatible with the Ender 3.

Actually, I just found the name of my 3D Printer - It is ADIMLab Gantry ( https://www.youtube.com/watch?v=SlsQ9LHkffk)

Let's check if the pi detects the printer at all

Log into your pi via ssh then disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

That looks good so far
Select port /dev/ttyUSB0 and try baudrate 250000.

That Worked!!! /dev/tty/USB0 and Baud 250000. I am sure that I had tried all different port and Baud rate configurations but this one worked. Thanks so much!! Now we can really get cooking!!

Thank you

Darrell Buck

1 Like

Glad it worked :slight_smile:
Happy printing :tentacle: