Help to recovery octoprint backup

What is the problem?

the problem is that when i try to restore the backup

It's very frustrating, I don't remember commands and actions, I tried to run multiple instances, but what I got was to ruin mine, when it restarted it went from version 173++ to version 1.4 and I lost part of the network configuration "fixed ip" plugins and it was clean :slight_smile: functional but 1.4,

Error while running restore
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/plugins/backup/", line 1260, in _restore_backup
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/plugins/backup/", line 292, in on_install_plugins
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/plugins/backup/", line 914, in _install_plugin
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/", line 208, in execute
    return, **kwargs)
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/", line 244, in call
    all_stdout += process_stdout(p.stdout.readlines(timeout=0.5))
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/", line 236, in process_stdout
    return process_lines(lines, self._log_stdout)
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/", line 229, in process_lines
    processed = self._preprocess_lines(
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/", line 498, in _preprocess_lines
    return list(map(self._preprocess, lines))
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/", line 517, in _preprocess
    return to_unicode(clean_ansi(text))
  File "/home/pi/oprint/lib/python3.9/site-packages/octoprint/util/", line 57, in clean_ansi
    return _ANSI_REGEX.sub(b"", line.encode("latin1")).decode("latin1")
UnicodeEncodeError: 'latin-1' codec can't encode characters in position 5-43: ordinal not in range(256)
Restore failed! Check the above output and octoprint.log for reasons as to why.
Removing temporary zip

What did you already try to solve it?

I spent the night before trying to restore but...
I tried a new installation, my ouio 32/64 gb cards didn't work and the time it took to find out that the cards were faulty, I was confused because octopi 1.0** didn't install and repeated camera configuration commands, I saw this, hare the when it was difficult for me to put the camera to work and with this new version just in the camera that was missing the installation did not proceed... of course the defect was the memory card. I currently believe with the latest version octopi and octoprint 1.0 and 1.73 it does not restore backup, sorry for so many unnecessary words, it is part of everyday life to admire the printed pieces and the history of printing the photos. and may other things :wink: i see octoprint in my tv, i love it.

so i would like some tips to try to repair the old installation or put the history in this new installation
running for almost 2 years, that's what helped me to print something, so many gcodes and adjustments, even to align the bed, octoprint
thank you so much...

Have you tried running in safe mode?

run wonderfully, and frighteningly very well, when I saw what I had done I thought it wouldn't run anymore, but it doesn't restore backup 1.4 to 1.73

Did running in safe mode solve the problem?

no problem

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (12.4 KB)
browser.user_agent : Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/101.0.4951.41 Safari/537.36
connectivity.connection_check :
connectivity.connection_ok : true
connectivity.enabled : true : true
connectivity.resolution_check :
connectivity.resolution_ok : true
env.hardware.cores : 4
env.hardware.freq : 1200
env.hardware.ram : 913608704
env.os.bits : 32 : linux
env.os.platform : linux
env.plugins.pi_support.model : Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version : 1.0.0
env.plugins.pi_support.throttle_state : 0x0
env.python.pip : 22.0.3
env.python.version : 3.9.2
env.python.virtualenv : true
octoprint.safe_mode : false
octoprint.version : 1.7.3
systeminfo.generator : systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I think maybe. this new one is better. this card is already a little faster and it won't be as complicated as before.


the problem is not that big, writing this and reviewing the files, what I really want now is to thank everyone, for making everything easier and more beautiful.
thanks everyone. for everything

But tips are welcome...

It's an incompatibility issue with OctoPrint & the newest pip that's included in the OctoPi release candidate.

Unless you have a particular issue I would recommend using the stable release (0.18) or you will need to upgrade OctoPrint to the 1.8.0 release candidate version that contains the fix.

thank you for the words,

The path is the same. this version 1.8 is beautiful, many new details.

I will reinstall the plugins, and

in the files.
.octoprint/config.yaml -> plugin listing and settings
./octoprint/data/ "plugins data "

focus on PrintJobHistory

1 Like

Where is it,

edit file /boot/octopi-wpa-supplicant.txt -> wlan0 up


and I forgot my OctoPrint login

but I forgot my OctoPrint login
findit in .octoprint/users.yaml

i need improve raspberry camera ... new ?

install plugins, there are so many

edits/uploadsdbs ...


I thank you all for everything

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.