Help Upgrading to 1.4.0

What is the problem?
I took a break from using my printer, and recently wanted to get back into it (last used in 2018 according to my OctoPrint logs). As such, I reconnected with OctoPrint and it notified me of updates available. I upgraded a couple versions, but can't seem to go from 1.3.8 to 1.4.0.

What did you already try to solve it?
I tried to research the topic on this forum (in addition to trying to update again and restart/reboot my Pi), and think it is likely similar to this topic:

So I apologize for creating another topic, but I'm a bit confused by what to do. I'm sure it's something easy that I should know to do, but I just haven't messed with my PI or anything in a while and I am at a bit of a loss.

octoprint.log (63.9 KB) plugin_softwareupdate_console.log (270.0 KB)

I don't think I know how to check my OctoPi version (again, something probably simple I should likely know how to do).

Looking at your logs, you're running into the same No module named extern thing from your overall environment being ancient. I ran into this over the weekend when updating an ancient install myself. The proposed venv solution from the thread you linked didn't work for me -- maybe venv wasn't used years ago? However, what did work for me was upgrading setuptools with a little different command line: /home/pi/oprint/bin/python2 -m pip install --upgrade --force-reinstall setuptools.

Referring to the octoprint.log you shared, you are running OctoPi 0.14.0. The recent version is 0.17.0.
I recommend to do a new setup with the recent OctoPi image because there are few things missing in that old OctoPi version you are running that are important for OctoPrint 1.4.0

Ok, so this is absolutely one area where I feel very dumb. I tried to explore how to do this from Octoprint, and I can't figure it out. Maybe that's my problem, and I need to do it from the command screen within the Pi? I just haven't messed with that part pretty much since I put it together a few years ago, and all my updates since then have been through Octoprint.

Thank you for the insight. I'm going to have to figure out how to update the image (hopefully I can do so without losing my printer settings and other stuff). I will look through the guides section to see if it explains how to upgrade.

You are correct that you cannot access the terminal from the OctoPrint web interface. You'll need to SSH into the Pi or connect a keyboard and display to it directly. To my knowledge, there is no way to successfully upgrade from 1.3 to1.4 in the web interface. If you're going to reimage instead of upgrade, I would advise starting with a fresh sdcard instead of clobbering the one that you have. That way you can finagle with getting your settings ported over on your own time and you can always just boot up the old version again if you need to.

There's a thread on backing up and restoring here: