Help with setuptools and updating to 1.7.2

What is the problem?

I'm trying to update Octoprint from 1.4.0 to 1.7.2 but can't do it as I'm running a old version of setuptools

  • Python: 2.7.9 (you have: 2.7.12)
  • pip: 9.0.3 (you have: 10.0.1)
  • setuptools: 39.0.1 (you have: 38.4.1)

What did you already try to solve it?

I've tried reinstalling it running `pip install --upgrade --force-reinstall setuptools, but it tells me that is already running the latest version, setuptools-44.1.1

Tried doing this but I get an error related with pyserial 2.7

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

Can't access OctoPrint's System Information dialog as my version is old

Additional information about your setup

Running Octoprint in a OrangePi Zero using Armbian Linux 4.19.62-sunxi

My logs file
octoprint.log (78.4 KB)


You're better off setting up a fresh venv with Python 3 at this point. Make a backup just in case.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.