Trying to update from 1.4.0 to 1.6.1 but keep getting failures

What is the problem?

trying to update from 1.4.0 to 1.6.1 but keep getting failures

What did you already try to solve it?

Retried to update several times. Tried updating in safe mode.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No. If it had, I wouldn't be asking this.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

No idea where to find this in 1.4.0 . I've been looking everywhere.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.4.0, OctoPi 0.16.0, Prusa Mk3s, firmware n/a, chrome, mac 11.2.3

apparently I cannot post my log files in their entirety, as they are too large.

Zip them, then upload the zip. (13.3 KB) (26.6 KB)

Ah, cool. Good idea.

Please try the following.

  1. SSH into your OctoPi (user: pi, password: raspberry or whatever you changed it to).
  2. source ~/oprint/bin/activate
  3. pip install -U pip
  4. pip install -U OctoPrint
  5. sudo service octoprint restart

Thank you for your response. I will try and figure out how to do all of this this afternoon and I will report back. It's been so long that I've had to sign into the pi that it will probably take me some time to figure how to do it.

1 Like

I got a break from work and got to give this a try. This did the trick for me. Thank you for the support.