How can I max out resolution on my LogiTech C920

What is the problem?

The Logitech c920 has a max image resolution of 2304x1536, how can use all of that when I am capturing images for timelapse?

What did you already try to solve it?

I tried altering the OctoPi.txt file but no luck.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


That is the right method, could you post the contents of the file so we can check it has been done right?

Thanks for the response, attached is the .log file (I had to chance it from .txt so I could upload it here)octopi.log (2.5 KB)

Looks fine to me. Next would be get the logs, the command to run would be journalctl -u webcamd, to look and see if there is an issue displaying that resolution.
2304x1536 sounds off to me, are you sure this is a resolution that the camera supports? You could try 1920x1080, a more common one to check it is picking up the settings, then move on from there?

I want to max out the resolution. I like to edit in a little movement in Premiere Pro, so the larger the image the more options I have for applying some movement in post.
Here is the article I read that talked about the c920 and it's sensor size.

No guarantees that the driver is able to read that size I would say. If you run v4l2-ctl --list-formats-ext you will get every resolution that the camera supports listed. If it's not there, it won't work. Might be worth verifying with the logs and testing at lower resolutions that you are configuring it correctly.

Took a look and here are some screen shots. The 2304x1536 resolution only came up for 1st compression format and not the h264 or Motion JPEG.

Maybe I will try and match the frame rate of 2fps.

Still capturing the images at 1920x1080, any ideas camera_settings.log (5.4 KB) rendering_settings.log (1.2 KB)

Attached are the .json files from the test.