How do I install Octoprint on 64Gb microSD card?

What is the problem?

I tried installing Octoprint on a 64Gb micro SD but after using balenaEtcher (on a MacBook) I am only being shown a storage of a few hundred Mb.
Can someone help with this? ( please bear in mind I am using a MAC not PC ). Thanks

What did you already try to solve it?


Have you tried running in safe mode?

Not applicable

Did running in safe mode solve the problem?

Not applicable

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Latest Octoprint img file, Prusa i3 Mk3+, Safari, MAC Big Sur ver 11.3.1

That actually sounds normal. The image will have 2 partitions on it:

  • /boot which is small FAT partition that can be accessed from windows or other systems. this is likely what you are seeing
  • / which is also fairly small just after flashing, since it should auto expand on first boot. With a mac you should technically be able to see this partition, but it may not have shown up automatically, or it may be showing as a different 'drive.'

In any case, have you tried using it yet?

Hi there, No I have not tried to use it as I did not think it was worth going through all the hassle if it was too small. Now I read what you are saying I will give it a go and post back the result. Bit of a pain as I have to SSH into the Pi from a Mac ( no keyboard or Display ). Wish me luck!!
BTW is there any way to run octoprint from the Raspberry Pi 4 without overwriting the Rasbian OS?? Thanks

Probably a bit to get used to, but you should only need to do that to adjust system settings, like setting up camera resolution/fps, etc. It's not something you'll need to do much in most cases.

OctoPi is a customized version of Raspberry Pi OS (Raspbian). You can install other portions of it if you wish.
You can also start with a 'normal' install of Raspberry Pi OS, or any other Linux for that matter, and manually setup OctoPrint:

I did this for my own setup since I use my RPi4 for other purposes and it works well. You do need to do all of the parts if you want all of the functionality (webcam, etc). Don't just stop on the first part!

1 Like

Hi /TTalkington

OK, I tried booting up the Pi using OctoPi but nothing, I was not able to SSH into it and when I put the card back in the Mac it still showed as MS-DOS (FAT 32) 268.4Mb !!!
So still stuck at the moment, any thoughts?

You are definitely only seeing the boot partition then. That's the normal size for it.

It sounds like it's not connecting to wifi, so start there. Does your router show anything for it under connected devices? If so, try using the IP instead of octopi.local, etc.

If not, make sure you have the wpa_supplicant setup correctly.

edit: if you are absolutely convinced that something went wrong with flashing I suggest trying to flash a standard Raspberry Pi OS image and look at the results.

1 Like

If you can't get the network issues sorted headless, plug it into a HDMI monitor, it will tell you if the network is available, it makes it much easier to troubleshoot issues with some terminal commands. The size is almost definitely not the issue here.

Hi, thanks for all the suggestions.
I have double ( and more ) checked the settings in the supplicant file after changing the commented out bits in WPA/WPA2 and they are correct. In fact the same settings were used to install the Pi with just the Rasbian OS installed and it worked correctly and even updated itself over the network!!!
The Pi running octoprint just doesn't want to play!! I will try and see if a shorter HDMI cable will work. Thanks Guys

Hi Charlie, way back when this all started I did list in another post that the HDMI did not work to the monitor I had available. It did not detect the signal!!!! I think I might have sorted this out with the Pi4 under Rasbian but not sure if this will work under Octoprint.

Well the latest is this:

Installed the Raspberry Pi OS via BalenaEtcher and it works fine, edit the "octopi-spa-supplicant.txt" file using BBEdit or Atom, the Pi can see the network and shows up on the router as a connected device.
I can see the Pi desktop on the monitor via HDMI 1 & 2 and I can connect to the internet via wifi and update the Pi etc.

When I Flash a 32Gb card with Octoprint and then edit the "octopi-spa-supplicant.txt" file using BBEdit or Atom to the same wifi settings and install that and reboot the Pi nothing is displayed on the monitor, nothing is seen in the router!

I have tried 2 different 32Gb cards and a 64Gb card but just cannot get the Octopi to work!!!

Can anyone shed some light on this please or would anyone in the UK be able to flash a 32Gb microSD card and post it back to me?

Cheers guys

Can you share the brands of the not working SD cards?
And of the working one as well?

All cards are San Disk Extreme Plus 32Gb & 64Gb

Hmm, they are known to work well.

I did not think it was the card as two of them are brand new!!

You may check these cards:

Even new cards can be faulty

nothing untoward found!!

I believe I have now installed octopi on the Pi 4 and it is showing on the router but I cannot log on to it in the web browser.
The IP info is /24
Any ideas?

Are you able to log in via ssh?

No, I am unable to log in from my Mac using the SSH commands shown in many you tube videos and google searches!

I guess there is also no output on hdmi?
We should try another flash tool.
Try it with the raspberry pi imager