I can't install any plugins from the repository, it is unreachable

Here's a couple things to try:

  • Make sure the server you are running OctoPrint on is connected to the internet and can reach plugins.octoprint.org. Try SSHing in and doing a ping google.com and a ping plugins.octoprint.org. Both should succeed without any errors.
  • Make sure that OctoPrint's connectivity check is setup and working correctly.
  • Finally, make sure your server's local date and time match reality, otherwise the https connection to the plugin repository will fail. SSH into the machine and issue date. It should report the current date in UTC.
1 Like

I have BOTH my octopi instances reporting the same error ("It looks like OctoPrint has currently no connection to the internet. Due to that it's not possible to install new plugins from the plugin repository or archive URLs."). I can ping google from either one and can run pip upgrades or whatever on each one. Weird that both machines are reporting the same error at the same time (they are on totally different networks, one at home and one in my lab here at the hospital)

Have you tried the "things to check" as mentioned above? Just being able to ping Google doesn't mean the connectivity check against the Google DNS server will work. There's a test button in the settings for that, see the second item for details.

OK, I opened chromium on the rpi and went to the repository, which I think is a pretty good test that I can succesfully reach that DSN address:

That still doesn't tell you though if the connectivity check can reach its configured endpoint. Which is why I said follow step 2. Check that:


So weirdly simply disabling the connectivity check made it all work perfectly (thanks for the crosslink to that post). From the command line on the RPi I can easily ping so not sure what's up with that (I thought maybe our IT blocked that DNS, but nope, no idea. but now everything is working so that's good)

I just set the connectivity checker to ping my router. It's obviously flawed but my internet is pretty stable and it's safe to say if OctoPrint can see my router, it can see the internet. I view the connectivity checker more as "am I connected to a network" rather than "am I connected to the internet" (even though the 2nd is probably what it was actually designed for).