Ignored commands "M0"

What is the problem?

I have a gCode I wrote for Leveling my printer’s bed, this one in particular is for my JG Maker Artist-D. I have it move the nozzle to the bed leveling location and the I send "M0" to pause while I adjust the bed in at that point. I have used this in the past on Marlin Printers and it always works from SD Card, but I understand sending it to the Printer may prevent OctoPrint from continuing it.

I never used the OctoPrint until recently and OctoPrint Pauses by not sending another command until I click Continue, but it keeps popping up messages every time until my screen is littered with popup messages that I have to close.

M117 Calibrating ( 1.1 of 4 )...
G1 X35 Y40 F9000 ;Left Front
M117 Calibrating ( 1.2  of 4 )...
G1 X35 Y275 F9000 ;Left Back
M117 Calibrating ( 1.3  of 4 )...
G1 X280 Y275 F9000 ;Right Back
M117 Calibrating ( 1.4  of 4 )...
G1 X280 Y40 F9000 ;Right Front

What did you already try to solve it?

I researched this issue and discovered that in Settings -> Printer -> Firmware & Protocol -> Protocol Fine Tuning, there are Blocked Commands and Ignored Commands. By default, Blocked Commands has M0, M1 as Blocked Commands. I understand this as OcotPrint does not send M0 to the host (Marlin), but it does not continue until I select resume print. With the M0 here, I will always get the popup messages every time M0 is processed.
I tried adding M0 to Ignored Commands which I understand to work just like Blocked Commands, but it just does not give me a popup notification.
1.) I tried adding M0 to Ignored Commands and Removed it from Blocked Commands:
Result: Popups still showed up.
2.) I tried just adding M0 to Ignored Commands and Blocked Commands at the same time:

Result: Popups still showed up.

Have you tried running in safe mode?

No, I did not think Safe Mode was a viable solution to try, but will if you want me to.

Did running in safe mode solve the problem?

No, I did not think Safe Mode was a viable solution to try, but will if you want me to.

Systeminfo Bundle

octoprint-systeminfo-20220602184916.zip (842.0 KB)

Additional information about your setup

OctoPrint Version: 1.8.1 (Was the latest downloaded by RaspberryPi image writer)
Printer: JG Maker Artist-D
Printer Firmware: Marlin 2.0.x Bug Fix
Browser: Microsoft Edge, Google Chrome, and Mozilla Firefox. (Technically the same browser) I use Microsoft Edge mostly because Windows 10 will not popup the on-screen keyboard in Firefox.
Operating System: Windows 10, Latest release and up to date.
Computers: On my Desktop I built, Microsoft Surface 3, Microsoft Surface 3 Pro
Operator: Me, lol :joy:

octoprint-systeminfo-20220602184916.zip (842.0 KB)

Sorry, forgot to add one very important detail.


Now it is working right?

There was an issue where it could not connect to the printer, prints were not finishing, and I rebooted the printer, problems persisted.

1.) I powered down everything.
2.) Disconnected everything.
3.) Powered everything back up.
4.) Reconnected everything.
5.) Connection problem to printer continued.
6.) Just powered down the printer and disconnected it from the Pi.
7.) Powered Printer Back up.
8.) Connected the Printer to the Pi.
9.) Now it works and M0 Messages do not popup anymore.

Not sure what changed, or if complete reboot is required after changing those settings or not, but that is how it happened. Unless the Matrix petted my Octopus to make it feel loved and happy, :).

Its working now, and I realized that I failed to mention I am using a Raspberry Pi 4. I also have a 3b if testing between the two is ever needed.

Thank you,

It was printing and printing and then when I tried to use it without the popup messages, now, it starts printing files it printed previously, and just stops after a layer or two.

I never heard of anyone who ever recommend it to me ever having these problems.

What am I doing wrong?

Can yo share a small gcode file?

Artist-D_IDEX_3D_Printer_Offset-Calibration.gcode (1.1 MB)

I printed this file twice with OctoPrint an d a few other files. Then something was going on with the OctoPrint and then it started printing for the first layer then it would just stop printing?

I uploaded the files to the SDCard on my pc and they print fine.

A few more files.

All of the problems started after I started using the M0 code and I tried to suppress them in settings. Then something broke and now it loses connection, files stop printing without cause, This is odd. My friends have used OctoPrint for years and they never had problems like this. So I am guessing that something with the M0 gCode is not right.

JGM_Artist_Bed_Leveling.gcode (1.8 KB)
JGM_Artist_Extruder_Leveling.gcode (8.6 KB)
JGM_Artist_Z-Gap_Left_Extruder_Leveling.gcode (4.0 KB)

Instead of M0 I would recommend to use the OctoPrint command @pause


@Ewald_Ikemann Thank you.

I will give that a try after I re-flash and reconfigure the OctoPrint. I was wondering if there was a way for OctoPrint to pause, I was thinking something like O0, but @pause makes more since as it isolates it as an OctoPrint command.

I just got the printer and have been trying to get it calibrated and understand its TLC required to use it. If just using @pause fixes the problem, then I would be happy to get OctoPrint going again.

So first, Thank you. I was getting frustrated losing hours to chasing a bug, or my novice experience with the OctoPrint.

I wanted to ask you, I have installed a test OctoPrint server on Windows 10. I have a couple of Microsoft Surface Tablets and was just thinking of running an OctoPrint server on them and connect to them localhost style. This way I can just make a local account that does not need a password, and I do not have to connect them to the internet.

It would basically be a dedicated touch tablet Isolated from the world. I can use a hub and direct connect to all of my printers, or have a dedicated tablet.

Have you heard of any issues with using windows 10 for the OctoPrint Server?


Octoprint on Windows 10 seems to run.

Here is a guide:

It does work, just was want to know if you had any info on stability. I created an up-to-date process using a video guide that did not work about two or three weeks ago.

I just installed it on the Microsoft surface and it is talking to the printer. I will have to wait for the SDCard print to stop before I can start a print form the tablet and give it a go.

file says gcode, but it is text instructions.

OctoPrint_Install - (.txt).gcode (3.4 KB)

Thank you again for your help!

@Ewald_Ikemann I tired your suggestion using @pause and it worked perfectly! Thank you for your time and help again!


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.