Installed "Thermal Runaway" dont show in PlugIns

Hello everybody,
i installed the "Thermal Runaway" from the "plugin repository"
and i can see it installed and activated in "plugin manager" but i can not see it in "plugins" list :frowning:

I attach screenshot.
Thank you in advance for any input!

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/95.0.4638.54 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 917016576
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
printer.firmware: Marlin 2.0.9_DW7.4 TM3D 5SMDBB (Jun 27 2021 20:52:41)
systeminfo.generator: systemapi

Hello @LoverBoy !

Have you already tried to reboot the system?

And please upload the systeminfo bundle that you can find at the end of the systeminfo . (139.9 KB)

i have reboot many times the last 24hours :frowning_face:

Thank you

First hand: You don't need the plugin. The feature is included in the printer's firmware:

2021-10-28 21:10:25,712 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Thermal Runaway, system stopped! Heater_ID: bed - echo:THERMAL RUNAWAY
| Last lines in terminal:
| Send: N1002 G0 X262.329 Y201.256*23
| Recv:  T:220.63 /220.00 B:45.27 /60.00 @:33 B@:127
| Recv: ok N1002 P0 B3
| Send: N1003 G0 X208.274 Y201.162*23
| Recv: ok N1003 P0 B3
| Send: N1004 G0 X208.274 Y200.027*17
| Recv: ok N1004 P0 B3
| Send: N1005 G0 X204.999 Y199.191*27
| Recv: ok N1005 P0 B3
| Send: N1006 M106 S127.5*79
| Recv: ok N1006 P0 B3
| Send: N1007 G1 F1500 E508.53662*62
| Recv: ok N1007 P0 B3
| Send: N1008 G1 F2100 X205.4 Y198.914 E508.57553*61
| Recv: ok N1008 P0 B3
| Send: N1009 G1 X206.011 Y198.706 E508.62705*84
| Recv: ok N1009 P0 B3
| Send: N1010 G1 X206.839 Y198.389 E508.69782*89
| Recv: Error:Thermal Runaway, system stopped! Heater_ID: bed

Second: You have an issue with the bed's heating.

The thermal runaway plugin may not show up because of this:

2021-10-28 22:14:10,072 - octoprint.plugin.core - ERROR - Invalid syntax in /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_ThermalRunaway/ for plugin ThermalRunaway
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/plugin/", line 711, in _parse_metadata
    root = ast.parse(, filename=path)
  File "/usr/lib/python2.7/", line 37, in parse
    return compile(source, filename, mode, PyCF_ONLY_AST)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint_ThermalRunaway/", line 320
    def runaway_triggered(self, heater_id: str, set_temp: float, current_temp: float, runaway_type: str):
SyntaxError: invalid syntax

The plugin is failing to run as it is requiring Python 3, and you are using Python 2. However, I can't blame you for not knowing that it looks like it states Python 2 and 3 compatibility, despite Python 3-only syntax being added in.

You should upgrade to use Python 3:

But as pointed out, it doesn't look like you need the plugin.

1 Like

Sorry im not familiar with codes and history :pensive: My cr10max works fine.
I on purpose disengaged the power wires to the heated bed and left on the thermistor only to test for thermal runaway.

This thermal runaway comes from tiny-machines firmware for the cr10max. But i dont like it takes 6 minutes to kick in :disappointed:

This is why i was trying to install this plug in , so octoprin will cut mains to the printer with a "solid state relay" i made.

i dont like that my printers thermal runaway kicks in after 5 minuts minimum :frowning:

ill try to study the forum how to upgrade to 1.7.0 because my updating tries fail and how to update to python 3 to instal this plug in and will let you know .

THANK YOU both for your time :heart:

what a 5h evening journey :sweat:
at last im now 1.7.0 with python 3 and can see "thermal runaway" plugin and tune it.
where r the good old days that all problems could be solved with a simple hammer .

Thank you all for your time

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.