Issues connecting to printer - Running 1.8.1 on RP 4b

What is the problem?

I am new to RP stuff and yesterday everything was working fine on my 4b. I have it set up to run my 3d printer, Artillery Sidewinder x2. The problem has risen that when i connect Octoprint to the printer, it does identify that 'serial port cannot be found'. I was able to move the printer with Octoprint, but not now. Any guidance would be appreciated to help fix this.
RP returns this in Terminal on Octoprint.
Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 0 port/baudrate candidates:
Changing monitoring state from "Detecting serial connection" to "Error"
Changing monitoring state from "Error" to "Offline after error"

What did you already try to solve it?

Tried the suggestion too increase timeout etc in Octoprint

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
octoprint.log (151.6 KB)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Communicating with the RP using Mac OS

Check that your Pi can see the printer with some of the troubleshooting steps above, and that it is powered on & the cable works properly. Every time you try and connect there is no serial port available for it to connect to, the OS is not giving it any candidates to try.

Yeah just looking at this now. Problem is Charlie 'im not expert at this stuff'. It might as well be written in japanese and the learning curve is massive!

looking at the ssh screen the pi definitely doesn't recognise my printer. Yet it cannot be a cable problem due to pronterface working fine with it. i can home the printer using pronterface etc.

Is there anything shown in dmesg? If you run dmesg -w and the plug in the printer, you should get some new output on the console. Can you share it?

Charlie definitely the RPi as i have tried 3 new serial cables today and none work. I linked the printer through pronterface and the serial port works on port 115200 on my Mac and it recognises the printer. I can home it with pronterface. i have ssh dmesg -w into the RPi and this what i get back:

953469] random: crng init done
[ 7.953491] random: 7 urandom warning(s) missed due to ratelimiting
[ 8.039539] 8021q: 802.1Q VLAN Support v1.8
[ 8.106072] Adding 102396k swap on /var/swap. Priority:-2 extents:28 across:150208k SSFS
[ 8.262678] brcmfmac: brcmf_cfg80211_set_power_mgmt: power save enabled
[ 8.467148] bcmgenet fd580000.ethernet: configuring instance for external RGMII (RX delay)
[ 8.467429] bcmgenet fd580000.ethernet eth0: Link is Down
[ 13.746527] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 14.671770] Bluetooth: Core ver 2.22
[ 14.671883] NET: Registered protocol family 31
[ 14.671899] Bluetooth: HCI device and connection manager initialized
[ 14.671943] Bluetooth: HCI socket layer initialized
[ 14.671967] Bluetooth: L2CAP socket layer initialized
[ 14.672003] Bluetooth: SCO socket layer initialized
[ 14.681215] Bluetooth: HCI UART driver ver 2.3
[ 14.681237] Bluetooth: HCI UART protocol H4 registered
[ 14.681341] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 14.681662] Bluetooth: HCI UART protocol Broadcom registered
[ 14.851554] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 14.851563] Bluetooth: BNEP filters: protocol multicast
[ 14.851575] Bluetooth: BNE

Here is the system bundle (49.8 KB)

To confirm, did you plug the printer in after you sent dmesg -w?

Can you check with another USB device that you can see something, to confirm the USB ports are working properly? Any USB device, a mouse, keyboard, webcam, etc. You should get some output appearing if you leave the dmesg -w command running while testing everything.

checked the ports with a USB mouse and still nothing happens. The mouse flashes momentarily and then goes off. Nothing appears in dmesg -w. I ran the command and and connected the printer.
Also plugged a card reader in and that lit up but no movement on dmesg -w.

I upgraded my Octopi and it set the default baud rate to the wrong rate for my printer. Maybe check that?

hi Geekdad how do i do that? thank you.

You can set it here:


for me the issue was tasmota plugin, once i disabled it printer could connect

Could you please upload a systeminfo bundle so @jneilliii can check if there are any issues with the plugin?

@jneilliii helped me solved the issue. it was OctoPrint-AutomaticShutdown and LayerDisplay that probably casued it, when i removed them octoprint mange to connect with tasmota plugin activated


What was strange that AutomaticShutdown was giving errors for indentation, but the latest release of the plugin lists that being fixed by @kantlivelong. Looking back at your log you provided you were one version behind at 0.1.4.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.