Kernel Panic while booting Octopi 0.15.1 on Raspberry Pi3 B


#1

Hello All this is my first post, I've searched for a similar issue but the search bar didn't gave me any similar case, if there is already one.. then I make my apologies in advance. :slight_smile:

What is the problem?
I've purchased a Raspberry Pi 3 B because I want to start using Octoprint, but when I plug to power I receive the following message:
"Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,2)"
I don't know how to fix this, it's my first time using a raspberry platform.

What did you already try to solve it?
Purchased an original Raspberry Power supply to see if the issue was due to under powering the board.
Formatted the MicroSD several times and downloaded Octopi 0.15.1 each time.
Purchased a new 16GB MicroSD.

Always the same message at the end of the screen:
"Kernel panic-not syncing: VFS: unable to mount root fs on unknown-block(179,2)"

Additional information about your setup
Raspberry Pi 3 Model B
Octopi 0.15.1
1x MicroSD 8GB
1x MicroSD 16GB

Can some one help me?
where can I find previous versions of Octoprint?

thank you in advance.


Octoprint not booting, Kernel Panic
Kernel Panic, out of ideas
#2

How are you putting Octopi on the SD card? What operating system are you using?


#3

I'm using etcher on Windows 10.
but I've tried also with Win 32 disk imager.


#4

okay, Etcher is what I would've recommended. It looks like this is common, for unknown reasons, and is solvable if you carefully step through this. Note your problem ends in 2, which is the second section.


#5

IOk, I've re flashed the SD, mounted the image on it, tried to follow the instruction on the link you gave me but I don't know what am I doing wrong, I start the Pi with the shift key pressed but still nothing, I can't get through the boot screen, I'm using a Trust 20964 as keyboard. is there anything else I can try?

I've opened the cmdline.txt file wityh notepad++ and this is what I have:
dwc_otg.lpm_enable=0 console=serial0,115200 console=tty1 root=PARTUUID=c7cb7e34-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet init=/usr/lib/raspi-config/init_resize.sh

can I do something from here?


#6

Again: You flashed the SD card and then you mounted the OctoPi image on it???

I did it this way: I flashed the image with Etcher onto the SD card and after this, I inserted the SD card into the RasPi and it works fine...


#7

Yes, I did that same thing... but it just won't boot up...

Maybe you can see something I can't.


#8

Hi, soo.. I purchased a new microSD 16GB (SanDisk) and a new USB card reader... this time from an EXPERT Store as the other two microSD's where purchased from a chinese store... I'm now flashing Octoprint into the new SD (I have all my fingers, arms, legs and eyes crossed)... if this doesn't solve the issue... I'll use the RasPi as a second platform to learn some coding like c++, c#, Python..


#9

Ok, it works!... I'm setting it up...

The issue was the Chinese MicroSD... I don't know why.. the difference from one made in china and the other made in taiwan... is basically none.

Thank you @tedder42 and @Ewald_Ikemann for your help..