KILLED PRINTER HALTED Please Reset after update 1.8.7

What is the problem?

I have been running several 16 hour prints
Then I decided to click the upgrade button to upgrade to 1.8.7
now I keep getting
I had just printed 6 x 16 hour builds
Then I upgraded and the next 2 crashed at random points with

Is there a way to back 1.8.7 out ?

What did you already try to solve it?

All the basic. reset, checked cables.
I sent the file to the CD card to test communications with no problem

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Additional information about your setup

Ender 3

Recv: echo:Unknown command: ""
Send: N65710 G0 X135.625 Y154.58535
Recv: ok
Send: N65711 G0 X135.265 Y155.693
Recv: TT::200.03200.03 //200.00200.00 BB::55.0155.01 //55.0055.00 @@::6969 BB@@::2323
Recv: echo:Unknown command: ""
Recv: ok
Send: N65712 G0 X132.484 Y160.12332
Recv: echo:Unknown command: ""
Recv: ok
Send: N65713 G0 X130.824 Y161.331
Recv: echo:Unknown command: ""
Recv: ok
Send: N65714 G0 X128.776 Y161.33135
Recv: echo:Unknown command: ""
Recv: ok
Send: N65715 G0 X127.116 Y160.123
Recv: echo:Unknown command: ""
Recv: ok
Send: N65716 G0 X126.273 Y159.07333
Recv: echo:Unknown command: "25753.6682 682"
Recv: ok
Send: N65717 G0 X125.194 Y158.968
Recv: echo:Unknown command: ""
Recv: ok
Send: N65718 G0 X108.567 Y176.22545
Recv: echo:Unknown command: ""
Recv: ok
Send: N65719 G1 F2700 E2672.68008
Recv: Error:Line Number is not Last Line Number+1, Last Line: 65666
Recv: Resend: 65667
Should resend line 65667 but no sufficient history is available, can't resend
Changing monitoring state from "Printing" to "Error"
Send: M112
Send: N65720 M11239
Send: N65721 M104 T0 S0
Send: N65722 M140 S0*97
Changing monitoring state from "Error" to "Offline after error"
Connection closed, closing down monitor
Closing down send loop

Please share the systeminfo bundle. Deleting the request does not abolish it.

And please use


for code uploads.

Here you go (178.8 KB)

One of the sections of the octoprint.log:

2023-03-08 00:02:50,221 - octoprint.util.comm - INFO - Got a resend request from the printer: requested line = 3032, current line = 3037
| Last lines in terminal:
| Recv: ok
| Send: N3029 G1 X141.116 Y155.259 E82.21469*101
| Recv: ok
| Send: N3030 G1 X141.492 Y155.548 E82.23046*104
| Recv: ok
| Send: N3031 G1 X141.722 Y155.749 E82.24062*99
| Recv: ok
| Send: N3032 G1 X142.123 Y156.031 E82.25692*103
| Recv: echo:Unknown command: "ÆÄ΄ÄČcŽæb„çNfgÌçïgæÌçæoïçÌîççïïççççï÷÷ïçïoÄg†F„äo„„ÄÄÆ„Ž†fÄ̌gÄîçæägçìÇÎççîçîãÎçgççïçïïççï÷ÿ"
| Recv: ok
| Send: N3033 G1 X142.619 Y156.324 E82.27608*110
| Recv: ok
| Send: N3034 G1 X142.922 Y156.569 E82.28904*109
| Recv: ok
| Send: N3035 G1 X143.112 Y156.789 E82.29871*104
| Recv: echo:Unknown command: "ïÜïçïÿÿwÿÎÆf€FÆÈÎæÎÌÌÆ̀ÌFƈÌææ†ÌÆÆçæîæîæîïwÿÿïçwÎfnææÆÄÌÌΊÌÌÎÆÌÂÌÌÌ̆æ†ÎïFî†îÎ戄ÀÄÌĎ"
| Recv: ok
| Send: N3036 G1 X143.306 Y156.968 E82.30749*97
| Recv: Error:Line Number is not Last Line Number+1, Last Line: 3031
| Recv: Resend: 3032

You have a quite bad and unstable USB connection from the Pi to the printer.

All the log is filled with such.

You may have a look on this thread:

It is interesting that this has been running flawless for a year and I just did 6 x 16 hour prints then upgraded and right at that time the cable went bad ????
OK I will investigate

How ever is there any way to down grade back to 1.8.6
That would make sense to me based on it was the last thing I did before this


Got some high power EMI producing devices around?

This is no issue either of OctoPrint nor OctoPi.
This is a hardware issue.

Nope. has not moved
1 year ago I had a bad cable which gave me unknown error
I bought some high quality ones and that fixed that. since then not one error that I could see but one can only look at the screen so long :slight_smile:

Just dont know why it would happen right when I hit the upgrade button but I do understand there was a unknown com error. I have extra cables. that I can try
however is there any way to down grade back to 1.8.6

You may use this:

1 Like

Thanks for your help
I will have to look further

Thanks @Ewald_Ikemann for the help
So just to follow up and to share my hair pulling exercise :slight_smile: And give the thread some closure

Well this has been fun :slight_smile: Not :slight_smile:
OK so as I said it work perfect for over a year. I just printed a bunch of 16 hour plus prints with no issue that I could see. I do keep my eye on the log but saw nothing.

I literally finished a 17 hour print, then upgraded to 1.8.7, and then started a 22 hour job. it went 4 hours and errored out. OK that's just one in a row so started it again and got into it for an hour and it errored out again. Hmmm

I sent a file to the SD card which took over an hour with no errors. Hmmm

Thats when I reached out to the group

I did swap cables and every cable was showing badish now and they are good quality cables WTH :frowning:
Interest. enough, Logic says I have to put it back to the last know good state. So thanks for the link, I rolled it back to 1.8.6 and it worked. WTH ! OK now I am stumped as I do agree, it certainly looks like a hardware issue. So I played with it more and then started to see some communication errors again. I pulled some more hair :slight_smile: It just got worst and worst as I touched it. but some times it would just start working again. Just to mess with me :slight_smile:

So after hours of trying different things to replicate the error with some hints but no repeatable success. Here is my best guess,
I assume I have some sort of ground issue
It is so hit and miss I can assume it was me touching the machine and or the machine vibration when it prints and when uploading a file to the SD card the machine was not moving so that might be why that worked. .
I started to add jumper wires for grounds between the PS and Rpi and Controller ...
When I checked I assume over time some of the bolts came loose a bit from the vibration. So I re tightened all the bolts
I measured out the grounding on the ender and add a jumper from the Rpi 3 frame ground to the PS of the ender.
In this state it has not failed yet, although I have not printed a large job
In other states, It may or may not give me a Communication error.

It is my best guess and is the only way I can make sense of it :slight_smile: I guess time will tell

What a coincident that it showed its ugly head right when I hit the update button. But did wanted to get back to a state that I knew was working Again thanks for the Link

I would like to say it was a good learning exercise but that would be a lie :slight_smile:

Thanks Again and I will cross my fingers and toes

Strange , I have the same issue, known working RPi, cable and Ender 3 V2, now keeps randomly halting after 4 hours on last 3 print attempts with exact same serial error. This has only happened since I upgraded Octoprint. Not even moved the printer from its enclosure.

Yes I not sure yet. I thought maybe the update sent a code the Printer didnt know but I can see the garbage. then I though well maybe it was handling errors better before. as it looked like the printer was asking the line to be resent and Octo Print kept going
Thanks to @Ewald_Ikemann I down graded.
I will stay at 1.8.6 a bit longer just to be safe and will run a bunch more jobs :slight_smile:
FYI the down grade was really easy, copy past, wait, done :slight_smile:
Hope you find it. It defiantly had me thinking, and I hate thinking :slight_smile:

BTW, I foud this at the end of your log:

2023-03-08 15:42:35,301 - octoprint.plugins.pi_support - WARNING - This Raspberry Pi is reporting problems that might lead to bad performance or errors caused by overheating or insufficient power.
!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

Thank you so kindly
Yep I saw that, it was one in a row, most likely when I was messing around with it to find the problem.

My update here is, That after retightening all the screws and adding a ground wire from the Rpi to the PS I have run several long prints with no comm errors yet. and I did down grade to 1.8.6 and will remain here for a little bit just to make sure.

So to me a key thing was I could upload a large file to the SD card which, I assume is printing to the SD, with no Comm errors. The errors only came about when the machine was physically moving. Therefore I concluded the noise is coming from the machine itself and a bad grounding point some where. It was just a really good coincidence that it happened right when I upgraded the Version between jobs. Wow that was unlucky timing

While I have everyone's ear. I am an old school electronics guy by trade and I have several machines that run Gcode. For example I have a CNC machine in a noisy environment with lots of other big machines around it that I had to ground and isolate the crap out of the CNC machine :frowning: I am also on other sites and there are so many issues over interference on the communications cable. Which makes me ask why we went from 9600 baud to 115k. . I know we needed to go faster but that seems a big jump and it is so susceptible to noise . In my day :slight_smile: the machines and most of the microchips that I programed, you started at some low Baud rate and jumped up from there. The code is not much to change the baud rate on init. You go as fast as the environment will let you without getting errors

I understand my CNC machine and dust control making that much noise, I was surprised to see all this noise on an Ender machine. Guess I learned something :slight_smile:

Just my thought of the day :slight_smile:

Thanks for the help

If you are building your own firmware for the machine you can set the baudrate that it communicates at - OctoPrint supports whatever baudrate you configure it to use, as long as they talk the same you'll be fine.

Thanks Yes when I was younger I did a lot of that but I have too many things on my plate and to be honest I am just too dang lazy :slight_smile:


Update: Bad Luck :slight_smile:
Well not to take up every ones time but it is a interesting turn of events
As I said above I was printing perfect for over a year on this configuration. I was in the middle of printing long jobs, All were perfect However there was a Upgrade message that I was ignoring for now :slight_smile: I then finally decided to upgrad and the next two jobs were aborted with communication errors and unable to recover.
Well it turns out right at that very moment It would seem that I was receiving EMI noise after running fine for more then year with no changes to the environment . So I tighten all the screws and added grounds. In particular one between the Rpi and the PSU
I printed a job perfect and the the next looked like crap. Turns out it is a new brand of filament and the nozzle clogged, So I cut back the tube and replace the nozzel. I got one more good print in and then crap again. WTH !!!. I found out the extruder pressure arm broke :frowning: Well I knew I would have to upgrade it some day :slight_smile:

I am really hoping that bad things only come in threes so I can get back to printing again :slight_smile:
And I really need some time to grow my hair back after pull it all out. What a turn of events :slight_smile:

Happy Printing

That happens to every plastic pressure arm sooner or later.
May I suggest a bmg extruder? They're awesome.
Just make sure that the gear on the extruder stepper is removable. The geniuses at creality decided to press it on the shaft on my second ender. I guess I could remove it with a dremel or something similar...

You can also try this - it worked in some cases

Thanks @PrintedWeezl

Yes I knew it would break someday. I have a metal that I just received. I should have been smart and ordered it a long time ago. I am pretty good at fixing things, therefore for a temp fix, I opened up the crack. put in ABS glue, then drilled a couple of very small holes. I cut groves around the outside edge so I could wrap a 20 gauge wire around it all to act as a binding/ compression strap. It is now copper reinforced :slight_smile: That got me through the weekend. Right now it still printing perfect on the temp fix :slight_smile: The upgrade is on tomorrows list todo :slight_smile:

Yep I got the pressed on gear. If I ever have to take it off I figured the best way is to build a mini gear puller. Basically 2 small medal flat bars and a couple of small bolts :slight_smile:

I did read that about the display cable and yes I have it on my list to shield. Thanks as I did not read that thread
I am just amazed it ran over a year with no errors and then .... Oh Well I guess it keeps life exciting :slight_smile:


1 Like

So just a funny update
I said I used a little ABS pipe glue and I wrapped a piece of 22ish gauge solid copper wire around the plastic that hold the bearing mount. (the place where it cracks) . I banded it with a piece of old school phone wire :slight_smile: That got me through the weekend. Woot Woot.

I ordered a steel upgrade kit and it got here Monday morning. Apparently I was motivated to fix the old lever but then the lazy side of me kicked. I have been printing non stop and the piece of copper wire is doing a great job so there it stays for now. :slight_smile: I will get to it some day :slight_smile: And I order a new Ender Neo

Happy Printing

1 Like