Layer shift when Pie is connected to printer

What is the problem?

hello everyone ! I have a problem with my new CR-10S pro V2 and my octoprint.
I tried printing a model while the Pie is connected to my printer so I can see the process when I'm in work. I didnt upload the print Via octoprint, I used the SD card like a regular print.
when I came home I saw that the print had a layer shift in almost every layer.
I disconnected to Pie prom my printer, and printed again the same part using the same SD card (I thought it was a slicing problem/faulty SD card), but as you can see in the pictures the print went on perfect. what could be the issue here?

What did you already try to solve it?


Have you tried running in safe mode and if so did it solve the issue?

didnt try


i could really use some help :pray:

Sadly when you asked for help, you deleted the section that asked for logs. I have no idea what your problem is.

Please, enable serial.log, reproduce this issue and upload it. Most likely it is a firmware issue, but again I have no idea since you skipped that part of reporting a problem.


i didnt add a log cuz the serial log file is empty ('serial.log is currently not enabled), i got the octoprint.log could it help? Also I must admit that all of this "Octoprint" thing is kinda new to me....
And how could the pie make any change in the print if I didnt upload the print from it? I used the printer SD card

Well I suggest that you do upload the log, I told you to enable serial.log already - please do so. The FAQ page I linked you:

Explains that you should upload the octoprint.log and serial.log.

1 Like