Login issues after updates

What is the problem?

After updating, I can no longer open the web interface through chrome. I just sit at a white screen, when I try through Microsoft edge I make it to the login screen but I can't log in when I use my credentials to log in the screen flashes for a moment and stays on the login screen. I am able to use my phone to get to the login screen with chrome but have the same issue with Microsoft edge.

What did you already try to solve it?

I have tried restarting the pi to see if that will solve the issue but it has not. I changed the password through the command line in case that was an issue but still the same results.

Have you tried running in safe mode?

no

Did running in safe mode solve the problem?

n/a

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint.log (174.9 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

1.8.2, 0.18, Ender-3, marlin, Chrome, Windows

Try to start it in safe mode

There are a minimum of two sets of credentials used to interact with OctoPi / OctoPrint.

The first is the OctoPi (or whatever is your host OS) username and password. The username should be "pi" and the (default) password is "raspberry" which you should have changed. This set of credentials are used primarily for logging in via SSH or on a monitor and keyboard attached to the RPi.

The second username and password are used to login to browser based OctoPrint. This set of credentials were established when you first connected to OctoPrint. There is no default username or password so if you have forgotten them, let us know and we can provide instructions to start over.

Make sure you are using the correct set of credentials for the correct purpose. When you say you changed the password through the command line, I think you are confusing which credentials should be used where.

I changed the password to the octoprint user following the forgot password link on the login page

Is there a way to tell if it rebooted into safe mode through the command line? When I see it shows that the flag is there for safe mode on the next restart, it loads to the login page on the restart and doesn't seem any different than before. I am not too savvy with doing anything through the command line.

You can check the octoprint.log file - it is part of the startup message. Usually saved at ~/.octoprint/logs/octoprint.log.

Restart OctoPrint (maybe sudo service octoprint restart is your friend) then run something like tail -n 100 ~/.octoprint/logs/octoprint.log, to view the last 100 lines. You should see something like this:

2022-08-31 23:47:11,628 - octoprint.startup - INFO - ******************************************************************************
2022-08-31 23:47:11,628 - octoprint.startup - INFO - Starting OctoPrint 2.0.0.dev1839+gf3e23ad4b.dirty
2022-08-31 23:47:11,628 - octoprint.startup - INFO - ******************************************************************************

Or:

2022-08-31 23:47:32,268 - octoprint.startup - INFO - ******************************************************************************
2022-08-31 23:47:32,281 - octoprint.startup - INFO - Starting OctoPrint 2.0.0.dev1839+gf3e23ad4b.dirty
2022-08-31 23:47:32,281 - octoprint.startup - INFO - Starting in SAFE MODE. Third party plugins will be disabled!
2022-08-31 23:47:32,281 - octoprint.startup - INFO - Reason for safe mode: command line flag
2022-08-31 23:47:32,281 - octoprint.startup - INFO - ******************************************************************************

Clear your browsers cache and delete the browsers temp files.

I didn't think to check the logs for that portion for some reason, so thank you for that. While looking at the logs though I keep seeing an error popping up that I don't know what it means. I have seen in the logs that it shows when I log into the user account but the login screen just flashes and clears out the data to a blank login screen. Below is the error that I keep seeing repeat itself.

UnicodeDecodeError: 'utf-8' codec can't decode byte 0x9e in position 1: invalid start byte
2022-09-01 12:36:14,596 - octoprint.server.util.flask.fix_webassets_filtertool - ERROR - Got an exception while trying to apply filter, ignoring file
Traceback (most recent call last):
File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/server/util/flask.py", line 178, in fixed_wrap_cache
content = func().getvalue()
File "/home/pi/oprint/lib/python3.7/site-packages/webassets/merge.py", line 250, in func
data = StringIO(hunk.data())
File "/home/pi/oprint/lib/python3.7/site-packages/webassets/merge.py", line 80, in data
return f.read()
File "/home/pi/oprint/lib/python3.7/codecs.py", line 322, in decode
(result, consumed) = self._buffer_decode(data, self.errors, final)

Tried that and unfortunately still no luck.

That's usually the thing I do when first looking at what people have posted - I forgot to look at yours there as well!

The errors you've highlighted are probably the issue - not all of the frontend code will be loading properly so it will not load the UI correctly.

You could try a reinstall - note that there's no data loss with this process, it is harmless and so should be worth a try.

Sorry for the long delay I was just able to get to this and try. After the first attempt there was an error that mentioned updating the pip might fix and it did. Now I am running into an issue with one of the plug ins that I have.

ERROR: pip's dependency resolver does not currently take into account all the packages that are installed. This behaviour is the source of the following dependency conflicts. octoprint-obico 2.1.3 requires sentry-sdk==1.5.12, but you have sentry-sdk 1.9.8 which is incompatible.

I am going to look it up but is there a way to uninstall the plug in to allow the reinstall? That error stops the reinstall process.

In my case to solve the issue to uninstall the plugin via ssh/command line was solved by using this command.
~/oprint/bin/pip uninstall octoprint-obico

After I did that I followed Charlie's advice with the Octoprint reinstall and it solved the issue. The command I used to reinstall Octoprint 1.8.2 was

~/oprint/bin/pip install --force-reinstall OctoPrint==1.8.2 --no-cache-dir

Again thank you for the help everyone.

1 Like