Logitech Camera Not Showing in GUI

Camera model
Logitech C270
What is the problem?
Won't show up on OctoPrint. The light on the camera is on when I run mjpg streamer but the stream doesn't show up on the octo dashboard. After starting this post I tried to run the streamer again and it said that the http_output wasnt there, so I copied it back into the plugins folder(i had previously copied it out) and it still didn't work.

What did you already try to solve it?
I installed and ran mjpg streamer.
sudo ./mjpg_streamer -i "./input_uvc.so -d /dev/video1 -r 1280x720 -f 30" -o "./output_http.so"

Logs (/var/log/webcamd.log, syslog, dmesg, ... no logs, no support)
octoprint.log (162.7 KB)

Additional information about your setup (OctoPrint version, OctoPi version, ...)
I am using a Le Potato running Linux 22.04, octoprint version 0.2.3.
Camera Link : http://octoprint.local:8080/?action=stream

Hello @James_Sheridan

I assume you are talking about the OctoPrint Web GUI and not this plugin:

You may have a look on this:

Sure about that? Log says V 1.8.7

@Ewald_Ikemann Sorry about that, I just started playing around with Octoprint a few days ago so I forgot the terminology. I did mean the Octoprint GUI.

I changed the URLs back to what that post said (/webcam/?action=stream) and it still doesn't work.

And you are right, Version 1.8.7, Python 3.10.6 (I was looking in the wrong place)

If it helps, I was following this tutorial. https://www.youtube.com/watch?v=L3Sr8p9RdMw&ab_channel=JerryTravisSmith

Hey all,

I wanted to do a quick update because I still need help.

I did a complete redo, I switched to Armbian from Ubuntu and I got back to where Octoprint was running and accessible form the web page, but the camera still isn't working. I no longer have the error when I run mjpg-streamer.

As you can see im using ./mjpg_streamer -i "./input_uvc.so -d /dev/video1 -r 1280x960 -f 30" -o "./output_http.so" to run the streamer.

Using Video0 gives an error. I haven't tried video2.

Thanks in advance,

I fixed it.

The very stupid mistake was that I had not installed HAProxy. :man_facepalming: