M118 not working


#1

What is the problem?

Why the M118 command to open a message on octoprint browser only works on arduino?

What did you already try to solve it?

Have tried on duet3d Wifi, einsy board (original prusa MK3), Prusa (BQ hephestos)
I've tried to mess with yaml configs, and made a lot of testing

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

version OctoPrint 1.3.9 running on OctoPi 0.15.1

Duet |Firmware Name:|RepRapFirmware for Duet 2 WiFi/Ethernet
|Firmware Electronics:|Duet WiFi 1.02 or later + DueX5|
|Firmware Version:|2.02RC3(RTOS) (2018-10-17b2)|
|WiFi Server Version:|1.20alpha1|
|Web Interface Version:|1.22.4-b1|

Prusa BQ 2.5.2 #510

Prusa MK3 3.4.0 1327


#2

You might also try M117 Change to red filament... instead.

This causes the given message to be shown in the status line on an attached LCD. The above command will display Hello World. If RepRapFirmware is used and no LCD is attached, this message will be reported on the web interface.


#3

I'm not entirely sure what you are trying to accomplish, but the documentation of M118 says that the only thing it will do is instruct the firmware to echo back what you send to it via the serial connection, e.g.

>>> M118 Hello World
<<< echo:Hello World

If you want to display something on the printer's display, use M117 as @OutsourcedGuru already pointed out.

If you want to pop up some kind of message inside OctoPrint you'll need to write a plugin for that.


#4

O rly?


#5

This is what i'm trying to accomplish, and it actualy works but only on arduino, for instance in duet it does not, and in einsy board, and bq zuma board.

but once again thanks for your answers.


#6

I should have added "that doesn't also get displayed on the printer itself" :wink:

@Tiago_Elias Ah! Now I understand what you are trying to do, utilize the new prompt action commands. Those need to be in the format described here and that won't fly with M118 as long as it's prefixing the generated message with echo:. They are targeting firmware which intentionally implements them.

Also, could you please clarify what "and it actualy works but only on arduino, for instance in duet it does not" is supposed to mean? That it works with firmware running on an Arduino but not the one on the Duet? Can you share a serial.log or the contents of your terminal tab for both please?


#7

I have several printers all with octoprint because i like it more the interface.

So what i mean by it works on arduino but not on duet and so on, is that picture that i sent You earlier is from my actual setup working as a charm on my printer that as arduino board as a controller, although the same octoprint configuration doesn't work on my other printers with duet3d, einsy and bq zuma as a controler.

my printers are printing at the moment as soon as possible i'l send the serial log.

thanks once again


#8

@Tiago_Elias:
What @foosel tried to explain is, that it is not a matter of hardware, but of firmware.

M118 is established since Marlin V 1.1.4 . If your other boards (not that Arduino) run with firmware older than that, it can't work.


#9

@Ewald_Ikemann thanks, now that's make sense!!!


#10

serial (3).log (3.9 KB)
this is the log from the Duet3d controler (almost works if i refresh the browser while error on communication)