🇺🇦 We stand with Ukraine! 🇺🇦

Makerbot Replicator x2

Hello

I am able to connect the Makerbot Replicator X2 to the PI (Latest version), however, the prints are always offset, the bed (Z-Axis) are not correct and it seems that Z, X, Y coordinates are not correct!

I tried to grab gCode from Simplfy3D to use before the prints..

; **** Replicator 2X start.gcode ****

M73 P0 ; Enable build progress

G162 X Y F3000 ; Home XY maximum

G161 Z F1200 ; Home Z minimum

G92 Z-5 ; Set Z to -5

G1 Z0 ; Move Z to 0

G161 Z F100 ; Home Z slowly

M132 X Y Z A B ; Recall home offsets

M135 T0 ; Load right extruder offsets

G1 X-130 Y-75 Z30 F9000 ; Move to wait position off table

G130 X20 Y20 Z20 A20 B20 ; Lower stepper Vrefs while heating

M126 S[fan_speed_pwm] ; Set fan speed

M140 S[bed0_temperature] T0 ; Heat buildplate

M134 T0 ; Stabilize bed temperature

M104 S[extruder0_temperature] T0 ; Heat right extruder

M133 T0 ; Stabilize extruder temperature

G130 X127 Y127 Z40 A127 B127 ; Default stepper Vref

G92 A0 B0 ; Zero extruders

G1 X100 Y-70 F9000 ; Move to front right corner of bed

G1 Z0.3 F6000 ; Move down to purge

G1 X-90 Y-70 E24 F2000 ; Extrude a line of filament across the front edge of the bed

G1 X-100 Y-70 F180 ; Wait for ooze

G1 X-110 Y-70 F5000 ; Fast wipe

G1 Z0.5 F100 ; Lift

G92 A0 B0 ; Zero extruders

M73 P1 ;@body (notify GPX body has started)

; **** end of start.gcode ****

What am I missing?

When I print, I get OctiPi warning:
Object doesnt fit volume.
But the same file prints off the SD Card in the correct location, and size.

Hi @iq0099!

Have you set the profile parameters for your printer correctly in OctoPrint?

1 Like

Please clarify because I'm new and just had this printer for 1 week - (Used)

If you are referring to the profile in the settings, then yes.

here they are:

2019-11-01_18-39-50

2019-11-01_18-38-25

I can only post 1 image per reply Sorry!

The size warning function is beta status. You can switch that off in
Settings -> Functions and there the second item.
Having a look on your start script, I see large negative values for X and Y.
If possible, share a sliced portion of the beginning of a gcode file, also the usual logs come quite handy.

FLAVOR:Marlin
;TIME:2840
;Filament used: 1.3767m
;Layer height: 0.1
;MINX:95.964
;MINY:119.2
;MINZ:0.3
;MAXX:204.05
;MAXY:180.8
;MAXZ:3
;Generated with Cura_SteamEngine 4.3.0
M140 S65
M105
M190 S65
M82 ;absolute extrusion mode
; start_gcode
M117 Start Clean ; Indicate nozzle clean in progress on LCD
;
M104 S200
M109 S200
M109 R200
;
M107 ; Turn layer fan off
G21 ; Set to metric [change to G20 if you want Imperial]
G90 ; Force coordinates to be absolute relative to the origin
G28 ; Home X/Y/Z axis
;
G1 X3 Y1 Z15 F9000 ; Move safe Z height to shear strings
G0 X1 Y1 Z0.2 F9000 ; Move in 1mm from edge and up [z] 0.2mm
G92 E0 ; Set extruder to [0] zero
G1 X100 E12 F500 ; Extrude 30mm filiment along X axis 100mm long to prime and clean the nozzle
G92 E0 ; Reset extruder to [0] zero end of cleaning run
G1 E-1 F500 ; Retract filiment by 1 mm to reduce string effect
G1 X180 F4000 ; quick wipe away from the filament line / purge
M117 End Clean ; Indicate nozzle clean in progress on LCD
;
M117 Printing...
; Begin printing with sliced GCode after here
;
G92 E0
G92 E0
G1 F2400 E-6.8
;LAYER_COUNT:28
;LAYER:0
M117 INDICATOR-Layer0
M107
M204 S500
M205 X8 Y8
G0 F3600 X107.317 Y126.147 Z0.3
;TYPE:SKIRT
G1 F2400 E0

octoprint.log (71.6 KB)

I would guess that the clean-the-nozzle routine on your printer moves the hotend outside of the print volume space so that it can brush off any extruded/dangling filament. If so, these moves make OctoPrint believe that your print job has gone rogue.

Take the advice, visit the OctoPrint -> Settings screen and turn off this behavior by removing a check in a checkbox.

I could not find this setting..
By the way, Replicator2 was not connecting to Pi until I Installed the GPX plug-in.. Could it be there?

I base this on what I saw from your gcode. I'm familiar with a FlashForge printer which also required the GPX plugin. Upon startup, it would heat the hotend, move the printhead/bed in such a way that it could then slide sideways with the nozzle just grazing the left/front of the bed, thereby cleaning any extruded filament.

If so, then this—from OctoPrint's perspective—is being "out of bounds". The printer is trying to move outside of the rectangle you defined earlier in your OctoPrint profile.

As suggested, turn off the out-of-bounds check in OctoPrint's settings.

can I just mark it or remove it in the GCode?

By the way, this Gcode was copied from Simplify3D since its the only one working with this printer.

The LulzBot TAZ 6 (and Mini) have a wiper pad outside of the "defined" print volume but the solution I use is to check "Custom bounding box" and define the actual dimensions used. I think this is a better solution than turning off bounds checking completely.

1 Like

What would you suggest I use on this Makerbot Replicator X2..

You should align the bounding box to the values needed by your printer.
According to this:
G1 X-130 Y-75 Z30 F9000 ; Move to wait position off table
It should be at least -130 for X and -75 for Y

It is your printer so you will have to determine the final values with the goal of not getting an out of bounds error during a "normal" print using both extruders. When properly set, this custom bounding box should prevent errant gcode from damaging your printer.

The right extruder appears to have a wait position at X-130. Where does the left extruder wait?

It seems to be quite outside the bed. I have a T-Rex 3.0 now and the parking position is only X-47...