Missing .exe when installing on windows?

What is the problem?

I followed the steps to install octoprint on Windows 11 though this link: Setting up OctoPrint on Windows

The server starts up when in the command prompt using "octoprint serve"

My issue resides with the next sections on creating a shortcut and startup service. The files in the folder consist of the following (below) while the documentation states looking for octoprint.exe.

What did you already try to solve it?

I looked in the folder for the executable, but don't want to be clicking random things.

Have you tried running in safe mode?

Not needed?

Did running in safe mode solve the problem?

Safe mode not needed?

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20221013135505.zip (5.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint version:1.8.4
OctoPi version: N/A not on windows
Printer: N/A issue does not reside with printer and not connected yet
Firmware: N/A issue does not reside with printer firmware and not connected yet
Browser: Firefox V105.0.3
Operating system: Windows 11 Pro V21H2
Computer Specifications: Beelink SER4 AMD Ryzen 7 4700U 16GB RAM 500GB SSD

sounds like maybe you didn't activate the venv when installing octoprint and therefore it's found in your system python environment. If you open a command prompt and run c:\OctoPrint\venv\scripts\activate.bat and then run pip install octoprint do you then see the octoprint.exe in the correct location?

Another option is using my experimental windows installer.

doing .\activate.bat then pip install octoprint does not change anything in the directory.

Using your windows installer worked and added it as a startup service. Thank you!

New issue. Using localhost:5000 the local ip on port 5000 work on the device hosting the server, but the local ip does not load the site on any other device connected to the same network. Any ideas on that end?

Thanks for all your help!

Yeah, you have to use the computer's name or IP address on the network instead of localhost in that address. So something like You may have to modify window's firewall (or other security software) settings to allow the connection.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.