My Pi doesn't boot


#1

I was working on installing a Pi Camera on my Raspberry Pi 3 B+ that had Octpi loaded on it. During the various processes of setting it up I had the power on and was viewing it to check picture alignment. At that point I accidentally knocked it off the the desk and the power cord came out. From that point on when I plugged it in, I could see the red LED but nothing else. When I tried to access it from the octoprint interface it said the server was offline. Doing some digging it turns out I may have mess up the OS on the sd card. So I decided to re-flash the card and start from scratch. I did so. so far it is not working. I do not have the green LED light up when I start it up, just the red. Nor do I see it on my wifi. I have double checked and my network information and country are correct.

At this point I don't know how to check anything else to see what may be wrong.

I do not see any obvious items broken on the pi itself from the fall.

I tried a 2nd sd card and the have the same issue. If I had to guess I would say the OS is not loading. I will start from scratch with a new download of the OS but I am not sure that will help.


#2

If it were me, I'd start with a new Raspberry Pi 3B+ and start over. If you get that working transfer the microSD over to the other Pi and test it. It will likely fail and then you can consider troubleshooting what it is that you broke on it.

The way you're going about it now is just increasing variables (like re-flashing the card). So what if the card image has something wrong and the Raspi has something wrong, too? How would you know?

I will say that my brand-new Raspberry Pi 3A+ would have the same sort of indication as yours if I transferred over an OctoPi 0.15.1—imaged microSD into it and booted. I would get zero response from the green activity LED. I found this to be rather disconcerting since I thought I had a dead-on-arrival Raspi. But then I re-flashed with OctoPi 0.16.0 and it worked just fine; the earlier OctoPi has the June 2018 Raspbian operating system that doesn't yet support the newer Pi computers.

So... if you're using an older OctoPi image on the 3B+ it's going to behave like what you're describing.


#3

I assume "picture alignment" is for the camera. Try hooking a HDMI monitor to it and see if you get anything, but generally a nonbooting Pi means an invalid/corrupted SD card.


#4

Hi @BC320,

could you describe each step you make when you prepare the SD card for use with the Pi?


#5

I was hopping to troubleshoot without buying a new pi. I only have the one.
Yes, the picture alignment was for the pi camera I have. by alignment I mean I was setting it up at a location where I could clearly see the printer and print bed when I knocked the pi off the desk.
Here is what I did for both sd cards I tried:

  1. formatted with SD Formatter from SD Assocation
  2. flashed the newest version of octoprint using Win32 disk imager (same version as I had when it was working but a fresh download just to be safe)
  3. edited the wifi stuff using notepad ++
  4. plugged in sd card to pi
  5. plugged in power

results:
Red Led shows power but I get no lights showing access to sd card or OS.
Both sd cards work in PC.

I plugged this into my HDMI on my tv and there is no output.


#6

The entire installation method seems a little iffy to me. It's not necessary to format anything, Etcher will take care of things like that for you. Try this.


#7

I formatted the SD card so I could have a fresh card to work with in case the image on the sd was corrupted. SOP on any OS install should be a basic format followed by the writing or installation of said OS.
From what I understand Etcher is a disk imager just like Win32. what is the difference?

I will try it later to see if it makes a difference.

When you say it sounds iffy? In what way? is it just the formatting? I am assuming in order for Etcher to see the SD card it must be able to be identified in windows. I have formatted SD cards in the past for various uses where I had to leave a small partition otherwise windows would not recognize the card at all. I am not trying to argue, I want to understand where I went wrong and the reason it was wrong.


#8

The difference is: it works.

I'm a coder. If I start writing something that's on the .NET framework, I'll likely add "Win" somehow to the name of it. I'm guessing this is what the author of the Win32 Disk Imager also did. Neither Apple nor Microsoft really want to support the ext4 partition type. They easily could add native support for it if they wanted to but they're being jerks about it (if you ask me). As a result of this, any attempts on your part to format the microSD are lost efforts since tools like Etcher need to go into a low-level byte-by-byte overcopy of the media. It's like a restoral program, in other words. It's not writing files to a partition since Windows has no ability to create or mount an ext4 partition.

Also remember, I help Windows users all the time on here. There are two things that are getting in your way: 1) your imager and 2) your operating system/browser which are trying to "help" you in ways which are hurting you. When I say this, I mean the part where your browser downloads a zip file and then tries to automatically uncompress it for you and then makes errors of judgement in doing so. My tutorial takes this into account and attempts to avoid anything that might cause you grief. The tutorial may not make sense to you but I'm reasonably certain that if you follow the instructions you will get a good image flashed to your microSD.


#9

Ok.
I will try Etcher tonight when I get home. My browser doesn't try to uncompress but I will follow your guide step by step to avoid any of those issues.
I will post again after I try this.

Thanks for the insight


#10

What he said.

I'm operating under the assumption that your 'etching' process is to blame, that your pi is fine until proven otherwise. Heck, if you're in the 'states you can send me $10 and I'll put a proven-good octopi SD card in the mail to you.


#11

I followed the guide provided by Outsorced Guru just now. I still get a red led to indicate power but no other LED lights nor can I see the pi on my network. Plugging the PI into my TV's HDMI I have no output.


#12

None of that disproves the Pi vs SD card theories, though.


#13

How do you suggest I rule one out? I have only the one Pi.


#14

Right, you either need a second pi or a SD card that is known-good.


#15

I have a 2nd SD card that is known to be good and I cannot get it to work either.


#16

That doesn't disprove it, because your etching process isn't proven to be good.

Options: mail me your card, buy a second Pi, buy a preloaded SD card, or put the SD card in a unixy computer that can validate the partitions.


#17

And we know that you pulled the latest OctoPi image, right? (Because the earlier 0.15.1 would definitely behave just like this.)

Since it's a 3B+, you ought to be able to use an Ethernet cable and see if it responds (or connects to your network).

Note also that the plus model now supports 5GHz wi-fi. So it's entirely possible that if you have two zones (with the same SSID but different passwords) then this could be what could confuse it.


#18

I have the latest version.
I have tried both my 2.4 and 5 network.


#19

And when Tedder says Unixy computer, you can also do an Ubuntu Live CD or USB to temporarily boot up another computer. You don't have to install anything and it doesn't touch your hard drive.

Once booted, you insert that microSD card and verify that it mounts two partitions. At least then you know that the process worked, you have a good-looking microSD and you can then move on to troubleshoot this as either a hardware problem or a network problem.


#20

For what it's worth, I'm guessing that when the Pi was dropped it cracked the microSD connector itself.