My Print just do the commands in start GCODE and stop

What is the problem?
I'm a sort of newbie in Octoprint & Octolapse. It's been only less than a week since I installed a Octoprint & Octolapse for the first. I got no problem when I installed Octoprint only. It works very well. I was getting a issue after I try to use Octolapse. If I turn off the Octolapse, the Octoprint works well but once I turn on the Octolapse, the same issue appears. I don't know the reason and couldn't solve it by myself even though I tried almost everything that I can.
When I start printing with Octolapse turned on, my print, Anet ET4, starts heating the bed and nozzle and do the G28 command of homing after get reached the target temperature. Good up to here. For the next, print move nozzle to do the wiping nozzle which is written in start GCODE that I wrote. After finishing this wipe movement, my print just stop. I checked the 'Terminal' tap and found that Octoprint doesn't send any GCODE command further after sending commands written in start GCODE area. Please help!

Video:
https://youtu.be/mfzpSYKhLbQ

Serial Log:
serial.log (6.5 KB)

PS: Please consider my poor English kindly. I'm not living in English speaking country so that I'm not good at.

What did you already try to solve it?
I don't know python and a kind of newbie in Octoprint & Octolapse so there are not much than I can do actually. But I did approach a lot of configurations in Octoprint & Octolapse which I could guess has a thread of connection with this issue. tried tons of times but almost always the same. I could not succeed move further.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

I attached here Octolapse Log just in case. Many thanks in advance!
plugin_octolapse.log (1.3 MB)

안녕하세요 @Seong_Hoon_Choi !

First try to print in safe mode.
There is something that is initiating the cancelling routine. Maybe something in a plugin

...like Octolapse.

Thank you for the reply. Actually, cancelling command recorded in log file was activated by me manually. As I knew in many attempts that it is no use to wait any longer in this situation, I just canceled the print to make this log. I'll try to do in safe mode anyway. Many thanks again for your kind concern.

One thing I noticed:

Before you cancelled manually, OctoPrint sent M114 to get the coordinates of the printer. The printer acknowledged that, but did not sent the coordinates. Not sure if that is helpful, but all I could read from the serial.

Edit: Could you upload the octolapse log from the same time as the serial log you provided?

1 Like

I made logs by attempting a new print. Wish it helps you to find the solution. Thank you very much for your help.plugin_octolapse (2).log (4.5 KB) serial (1).log (6.0 KB)

To me it looks like Octolapse is trying to get the starting position with M114, but your printer does not provide it. You could try adding G90 (if you are using absolute positions, otherwise G91) after G28 and see if that fixes it. Also make sure that your printer profile matches your slicer settings/printer dimensions.
If that does not fix it, you could try following the usage guide of Octolapse, especially the test print section.

I tyied adding G90 already but didn't make any difference. As you may see my youtube video attached above, my printer, Anet ET4 has very unique home position. I guess this unique homing action might be the reason. Thank you.

What happens when you send an m114 via the terminal? Post any response you see there please.

I'm really happy to get you interested in this issue and thank you for this. When I send M114 via the termianl I just receive 'ok' as answer and that's all. And then Octoprint send M105 continually getting current temperature as answer as attached below;


Thank you for your help.

Looks like a problem with the custom firmware your printer is running. I recommend contacting the manufacturer and ask them to implement m114. I will research some alternative gcodes, but m114 is definitely ideal.

Will keep you posted, but i have to say that this is the first firmware ive seen not to implement this gcode.

1 Like

I'm sorry I can't fully understand what your comment means and what I'm supposed to do. Please explain more in detail and easy to understand. Thank you!

Ignore it, the issue is indeed the lack of a proper M114 response as @FormerLurker pointed out. Your printer doesn't report back its position when asked about it. That's a firmware fault or rather a missing feature. So you have two options here.

Option 1

Flash some firmware on your controller that supports position reporting. As @FormerLurker already recommended you might want to contact your firmware manufacturer and ask them why they decided to not implement this standard GCODE.

Option 2

  1. Go into Settings > Serial Connection > Behaviour and uncheck "Log position on pause" and "Log position on cancel"
  2. Go into Settings > GCODE Scripts and make sure your pause, resume and cancel scripts do not try to use the position (look for pause_position or cancel_position being used) - by default this shouldn't be the case but you might have copied some stuff from other sources that does.
  3. Give up on using OctoLapse because I'm pretty sure it absolutely requires M114 to be supported - @FormerLurker is the final authority on that however.

Thank you so much for your kind instruction and regards. I'll contact the manufacturer to ask about m114. Thank you!

Thank you for your reply. I'm not sure I can fully understand your instruction but I'll try to follow. First of all, I think I should contact the manufacturer to ask about M114. Thank you!

I tried option 1 but the same and regarding option 2 I can not find such things in GCODE Scripts tap. Thank you anyway. I should wait for the answer from the manufacturer.

When contacting the manufacturer, feel free to link this github issue I created for the problem. I'd be more than happy to explain to them why this gcode is so important.

Thanks!

OH! You are so kind. Thank you very much. I'll inform them the issue you created. Thank you!

I got a reply from Anet as below;

Dear friend,

Sorry, we are still optimizing the firmware. It is not supported(M114).

Thanks & best regards