New Install - Can't connect To Printer - HELP!

What is the problem?

Once my RPi4 boots up, I can connect to it through octopi.local, but when I click on "Connect" I get errors. Some suggesting I choose the Serial Port manually. When I go to the drop down for Serial Port, I only have AUTO available. I can't find or connect to my printer. Trying to connect RPi4b 4G to an Ender 3 v2.

What did you already try to solve it?

tried using 64 gb card, and 32 gb card.
Formatted multiple times. FAT32 format. Downloaded img file from octoprint. installed via Belena Etcher.
Tried 4 different usb-a to micro usb cable.
Put tape over the power pin of the USB-A side of the cable.
Powered off and on my printer while connected. Refreshed browser after connection.
Firmware update for my printer.

Everything I do results in the same outcome.

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 0 port/baudrate candidates:
Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."

I did get one error one time mentioning it could not connect so Serial port automatically, and had to be done manually. But there was nothing in the drop down for Serial Ports.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

Its this same lines over and over (each time I hit connect):

Changing monitoring state from "Offline" to "Detecting serial connection"
Performing autodetection with 0 port/baudrate candidates:
Changing monitoring state from "Detecting serial connection" to "Error: No more candidates to test, and no working port/baudrate combination detected."

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Using MacBook Pro to flash microSD card.
64gb or 32 gb card.
Raspberry Pi 4b 4gb
Ender 3 v2

TiA!

Let's see if your pi detects the printer at all

Turn on your printer, then turn on the pi.
Log into your pi via ssh then disconnect your printer, connect it again, enter dmesg | tail -n 20 and post the output here.

If you need help with the ssh part


Scroll down and start with the Connecting to Your Raspberry Pi over SSH part.
The first part is already done for you in the octopi image.
1 Like

Thank you for your response, I’d like to follow the steps illustrated above.
You’re going to hate me for this, but for some reason I can’t see my Pi on the network to determine it’s IP address.
But I know it’s online, as I’ve connected to it through my browser. I did the entire setup wizard on the Octopi. I do have a monitor and keyboard I could hook up to the Pi, but I don’t think there is anything to display?

You can also connect to it's hostname - octopi :slight_smile:

One simple way to get the ip is to just ping the pi.
Open cmd or powershell and enter ping octopi

I was recommended to see if I could connect my printer to my computer and see if my slicer would see it. But I'm not seeing anything there either. So, now I'm down to either, Bad USB cable (tried 5 cables now), bad USB port on the Ender, or firmware update made the serial port non-functional.

I am having the same problem. Printed Weezl, my dmesg output below. Guess it is the USB connection. I tried another cable and no go.
Thanks!

pi@octopi:~ $ dmesg | tail -n 20
[ 10.490642] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 10.490654] brcmfmac: power management disabled
[ 10.980107] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 10.980122] 8021q: adding VLAN 0 to HW filter on device eth0
[ 14.471919] Under-voltage detected! (0x00050005)
[ 16.155107] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 17.012500] Bluetooth: Core ver 2.22
[ 17.012600] NET: Registered protocol family 31
[ 17.012608] Bluetooth: HCI device and connection manager initialized
[ 17.012632] Bluetooth: HCI socket layer initialized
[ 17.012646] Bluetooth: L2CAP socket layer initialized
[ 17.012690] Bluetooth: SCO socket layer initialized
[ 17.036807] Bluetooth: HCI UART driver ver 2.3
[ 17.036823] Bluetooth: HCI UART protocol H4 registered
[ 17.036915] Bluetooth: HCI UART protocol Three-wire (H5) registered
[ 17.037137] Bluetooth: HCI UART protocol Broadcom registered
[ 17.424817] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 17.424825] Bluetooth: BNEP filters: protocol multicast
[ 17.424841] Bluetooth: BNEP socket layer initialized
[ 20.711820] Voltage normalised (0x00000000)

@stikako
I see. You could look inside the printers usb port (with a flashlight or something). Maybe there is a bent pin and you're able to bend it back.

@techydoc
the first thing I notice here is the undervoltage warning.
Make sure you're using a sufficient power supply and no phone charger.
I assume the printer is turned on and plugged in into your mains power.
Try this Put tape on the 5V pin - Why and how
When you're done with the tape mod unplug your pi and plug it in again. Sometimes the usb controller crashes and doesn't work again until the pi has been fully power cycled.

If that doesn't help try the same as @stikako - connect the printer to your pc and test if it works with something like pronterface .

I saw the voltage warning to. I was using the power supply from the kit. Just checke it is 0.5A!!. Ordered a new 2.5A supply. Also ordered a new USB cable.

The printer was on. I tried to connect the printer to my laptop and see if I could see a USB device, could not see any. I will look at the pronterface site. I will try the other items you suggested. Thanks!

OK, so on my Mac in terminal, I've tried just typing the command "ping octopi". and all I get is this:
ping: cannot resolve octopi: Unknown host
But, on octopi.local, I can turn off my Rpi, reboot it, etc. So I'm clearly connected to it.

Bad cable was my problem.

2 Likes

stikako, instead of using ping, open terminal and type: ssh pi@octopi.local

If you are asked to accept a key, then you are connected. type yes. When asked for a password, enter: raspberry

What was the difference in the cable?
I’ve tried 5 cables. Nothing worked.
I went to the store to pick up a new cable that states it transfers data. But can’t return it if I open it. (COVID). It was inexpensive, but I have many of these cables, so don’t need an extra.
I don’t know how the 5 cables I have are inadequate, but I’m out of options.
I should be getting a second printer sometime this week (fingers crossed), and I should be able to narrow down what the problem is just by setting up another identical printer on original firmware.
If it works, it’s either port or firmware. Then I’ll update firmware. Works, it’s my port. Doesn’t, it’s firmware. If it doesn’t work right off the bat, then it’s most likely cable, or some sort of configuration that’s required on the printer to access it.

Weird to have 5 cables that are faulty, seems like it is not a cable issue.

The cable I purchased: https://www.digikey.com/product-detail/en/102-1492-BL-F0050/1175-1808-ND/6005091

Maybe I've overseen it, but to what printer do you want to connect?

Should be clear. This was for the Ender 3 v2

It was the cable!

FIX: Bought a “data transferable” cable. Worked right away.

Thank you for your help!

Thank you as well for all your troubleshooting and help!
Still can’t see my Pi on the network and don’t know what it’s IP address is, but I bought a new cable, and it’s working!
Well on my way to success!

You may connect a HDMI monitor/TV to the Pi.
At the end of the startup sequence the current IP address is displayed.