New Pi V2 Camera on PI 4B not working

New V2-8 Megapixel, 1080P@30fps RPI CAM connected to an RPI 4B

Up until now, I was using a Microsoft USB camera but I switched to the PI camera. I can't get the camera to work. I don't know for sure if it is because I am switching from USB to PI.

I ran raspi-config to enable the camera and rebooted.

I edited octopi.txt and added:

camera_raspi_options="-x 1920 -y 1080 -fps 30"

I ran the vcgencmd get_camera command and it shows as ok.
supported=1 detected=1

tail /var/log/webcamd.log shows:

Rotation 0, hflip No, vflip No
ROI x 0.000000, y 0.000000, w 1.000000 h 1.000000
o: www-folder-path......: ./www-octopi/
o: HTTP TCP port........: 8080
o: HTTP Listen Address..:
o: username:password....: disabled
o: commands.............: disabled
i: Starting Camera
mmal: mmal_vc_component_enable: failed to enable component: ENOSPC
camera couldn't be enabled

I have my system fully up to date. Any thing else I can try?

My camera is labelled as IMX219. I think my issue may be because I need the Bullseye version of Debian for this to work. Can someone second that?

Not only do you need bullseye, but the current streaming stack doesn't support it as far as I know.

It's always useful to provide exact versions - the latest version of OctoPi is Debian Bullseye.

Try the below OctoPi image instead, which is testing the new camera stack:

I have downloaded and written the image. Will test it out tonight. I guess the camera instructions will be different for this image. Does anyone have a shortcut or link to the document?

There's a link in the issue above to some documentation if you need it.

The good news is that the image above works and my camera is fine. It took some digging around to get the camera to work. I think this is the summary of changes:

Edit /boot/config.txt
add the following line
change the following line from 1 to 0

edit /boot/octopi.txt
uncomment the following line

I got this from Profile - Josh_Watanabe - OctoPrint Community Forum from the following thread:
Arducam not connecting to OctoPi - Get Help / Webcams - OctoPrint Community Forum