No login from outside

Hello everyone!
Thank you in advance for helping in this forum :slight_smile:
I hope I provided all the information needed, if I forgot something: sorry, please just ask.

What is the problem?

I have created a second read-only user, so a friend of mine can watch the prints I do for him.
Login is no problem from within the local network via http.
But logging in from outside (a https-subdomain with an SSL proxy (Apache) for security) doesn't work.
If you want to try for yourself:
User: Test
Pass: TestTest

What did you already try to solve it?

I tried different users with different rights, but none worked.

Have you tried running in safe mode?

Nope, didn't seem to be an option for this issue.

Did running in safe mode solve the problem?

See above.

Systeminfo Bundle

Download bundle here:

Additional information about your setup

Printer: Artillery Hornet (via USB cable, 1,8m)
USB-Webcam: Logitech C525 (via integrated cable)
Internet: via LAN, gigabit switch, FritzBox 7590 router, fibre connection from Deutsche Glasfaser (1.00MBit/s up and 500 MBit/s down).
Connection from outside: subdomain connects to IPv6 on fibre internet and IPv4 via Kossmann EDV fixed IP-service, first contact is an Apache webserver running as SSL proxy, routing to http from OctoPrint.
OctoPrint running on Raspi 3B+, 16GB microSD, powered by original Raspi Power Supply.

Hello @David_Sallge !

You may have a look on this:

Another file-server?

You can upload your logs with no problems here. (89.6 KB)

Sorry for the file server - it's mine, just in the room next door.
I didn't see the upload-icon there, here's the correct upload.
Will check the guide (why didn't I find that when I searched for this on google?), thank you very much!

Edit: well, my solution (reverse proxy) is mentioned, but not how to achieve successful login...
I guess I'll have to look at the cloud solutions.

1 Like

Did you check out the reverse proxy configuration options examples?

EDIT: The only issue might be the line http://<myOctoPrintHost>:5000/, if you include the port there it won't work with OctoPi because of OctoPrint's service configuration only allows access from itself (haproxy in octopi's case). This can be modified to allow access directly to port 5000 if needed though. I think you can just use http://<myOctoPrintHost>/ instead though.