No longer able to connect ender 3 pro to pi

What is the problem?

2 days ago, after installing my new enclosure for my ender 3 pro and lifting it in, while also changing my nozzle, and connecting a new webcam I was suddenly no longer able to connect my Ender 3 Pro to my raspberry pi. It has been working for months up until now, but whatever I try now, I get the following error:

State: Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)

What did you already try to solve it?

  • For all tests, I disconnected the new webcam and there were no devices other than the printer connected to the pi (The webcam stream worked by the way)
  • Booting in safe mode
  • Changing the cable, I tried 4 different cables, I don't think they are non-data cables, is there any way for me to find out? The one I was using worked up untill now, so I don't know if it is possible that the 'data' part of it broke?
  • Connecting my printer to my computer (Windows 10). Windows recognizes a device but has an issue in my device manager, I get this error:
Driver Provider: Microsoft
Driver Section: BADDEVICE.Dev.NT
Driver Rank: 0xFF0000
Outranked Drivers: usb.inf:USB\DEVICE_DESCRIPTOR_FAILURE:00FF2000
Device Updated: false
Parent Device: USB\ROOT_HUB30\4&f01e21b&0&0


Have you tried running in safe mode?


Did running in safe mode solve the problem?


Complete Logs

octoprint (1).log (449.1 KB) serial (2).log (4.6 KB)

Additional information about your setup

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4389.90 Safari/537.36
connectivity.connection_ok: true
connectivity.enabled: true true
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1979641856
env.os.bits: 32 linux
env.os.platform: linux2
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.1
env.plugins.pi_support.octopi_version: 0.17.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 19.3.1
env.python.version: 2.7.16
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.3

My printer is the Ender 3 Pro with the BLtouch. I flashed the firmware once with the BLtouch firmware as Creality had explained in the video. I no longer know the exact version and since I can't connect my printer anymore I can't see it. I would not expect it to be a firmware issue since it was working fine, and suddenly without any changes to my printer it stopped working.

I can't seem to figure out the issue for the life of me, the only option I can think of something to try still is to re flash my firmware of the printer, that it got corrupted somehow, but I don't even know if this is possible from just moving my printer?
Another other possibility is that of the 4 cables, only the original cable is a data cable and the 3 others are not, and by moving it I broke the original cables data part. It was still powering my printer before I covered the 5V pin though, so its not like the cable was entirely broken (I don't see any loose parts in the cable either)

Am I missing anything, or is there anything else I should try still before re flashing the firmware / buying a new usb cable?

Are you able to connect manually with PuTTY?

I am able to connect to my raspberry pi through putty yes. I am also able to connect to the web interface of my raspberry pi. My octoprint is unable to make the serial connection to my printer though.

I mean on Windows can you connect to the controller via PuTTY? You could also try something like RepetierHost.If it won't work there then it won't work w/ OctoPrint.

The dev descriptor errors on Windows def makes me lean in the direction of hardware or firmware issue. Check your USB cable. Perhaps see if you can reflash firmware.

What do you mean with 'connect to the controller'? You do not mean the raspberry pi with the controller then? If you did mean the raspberry pi, I am able to connect to it manually through PuTTY, if you meant something else with the controller, please elaborate.

I guess reflashing firmware might help indeed, or maybe something is wrong with the usb port of the printer. I'm not sure what the best way is to find out.

The controller PCB should show up as a serial port that can be connected to via PuTTY. PuTTY does more than just SSH.

Cool, I did not know that. I managed to connect to it in PuTTY, the printer suddenly showed up in my devicemanager as a COM, I did try installing a driver earlier that I thought failed, but perhaps it was due to a restart.

When connecting to it in Putty I got the following output:

I'm not sure what I was supposed to see here or if this is normal or not?

I guess this proves at least that my cable is still doing fine?

I wouldn't rule out a cable yet but at least you have some kind of communication going.

So now it's worth trying something like Ponterface on Windows to see if that works. If it works there (do a basic movement test or something) then I'd try OctoPrint again.

Hmm alright, I'll give that a try. Does that mean that you think there's a chance that doing a basic movement on Ponterface will somehow fix the connection between the printer and OctoPrint? Since if I do a basic movement on Ponterface I still didn't actually change something, right?

If movement works in Ponterface then the controller is accepting commands. Should work with OctoPrint at that point.

I didn't get to try Ponterface, but this morning I tried once again to connect OctoPrint to my printer and suddenly it worked.. I then rebooted out of safe mode to normal mode and it still worked. Then I tried connecting my camera and now I'm stuck with the same issue again. I plugged out my camera, tried safe mode again but I can't get anything to work now.

It seems like plugging in my camera once, even though it works, breaks the connection to my printer for a while, and then it randomly starts working again. Any idea what I can do about this? Rebooting the devices in any combination does not seem to work.

Perhaps the camera is drawing too much current. What power supply are you using for the Pi?

I'm using the official raspberry pi power supply for the pi4. I don't expect that to be the issue since then it should work once I disconnect the camera, which it does not?

I've changed my cable specs. I only buy HIGH QUALITY data cables. I only use 1' or 33 mm cables. My Rpi's set just in front of the USB ports. I'm using Pi4-4gb's, I use a USB 2.x port. Then there is the port discovery, I unplug the cable, reboot the printer, connect the cable. That usually works. It is a "chicken & egg" thing... You have to find what works for you!

Hmh, do you reckon 33mm cable vs for example 300mm cable matters that much? Perhaps I should get a shorter high quality data cable as well then if the problem occurs again. I somehow got it to work by just rebooting many times and trying different combinations of plugging the cable in and out, and now it works even on reboots of the printer. For now I'm definitely not changing any cable at all, but if it would break again, I guess I'll purchase a short cable and see if that improves anything.

I think this is a typo. He wrote:

That is 1 foot or about 330mm...

Ah, for some reason I thought he meant 1 inch, not used to the imperial system/notation, thanks for clearing that up.

Still find it a bit weird that it was working fine, then randomly stopped working for a while and then started working again. I see more people having similar issues where it suddenly just works, and I would find it weird if the cable sometimes consistently works, and sometimes consistently doesn't.

For now I guess I wait until it breaks again so I can try to fix it hopefully more permanently

So I've got a follow up on this: I worked on some extruding issues a bit more, during which I shut down the printer and disconnected all the cables, and surely enough after booting everything back up, I had the same issue again.I couldn't get it to work at first, until suddenly at some point in randomly worked again. At this point my camera was not plugged in, but I was able to make the connection. Then I plugged in the camera, executed sudo service webcamd restart and the webcam feed worked. At this point, I got an issue in the conection:
Instead of
State: Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)
I got something like this error:
Offline (Error: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)'

I saw in some other posts that they recommended running the 'dmesg' command, and that one seems to have some intersting logging I hope someone can help me with:
dmesgLogs.log (54.7 KB)

Most import lines are at the end because all the first lines just seem to be from startup.
In general, my camera was working on amaUSB0 and my printer on ttyUSB0.

I can see some interesting stuff going on after 4705.242244 and after 4991.877538 but I can't quite put my finger on it. It definitely seems like it is camera related, but I wonder if it is a power issue, or something else. (I am using the official rpi 4 power brick).

It looks like the combination of printer and webcam requires too much current. Do you still have tape on the 5V pin of my USB?

Initially it was in there, but whenever I tape the 5V it seems to come loose again after plugging it in and out a couple of times, currently that has happened again so the 5V pin of the USB between the printer and raspberry pi is no longer taped.

If it is indeed a problem of requiring too much current and my 5V pin of the USB between the printer and pi was taped, does that mean that the raspberry pi simply cannot power the camera, since it does not have to power the printer then? In that case, how come that whenever I plug in the camera, that always works?

Is it possible that I have to get a different camera that uses less power?