No MK3S Communication after Update to 1.7 with Python3

What is the problem?

Today I got the information that Octoprint with the Python 2 no longer works in the long run and should be switched to the version Python 3. So I have a new image with OctoPrint 1.7.0 Python 3.7.3 OctoPi 0.18.0 and since then the communication to the printer Prusa MK3S does not work anymore. But with the Python 2 version it still worked.

What did you already try to solve it?

Read octoprint log and find this:

Traceback (most recent call last):
File "/home/pi/oprint/lib/python3.7/site-packages/serial/serialposix.py", line 144, in set_low_latency_mode
fcntl.ioctl(self.fd, termios.TIOCSSERIAL, buf)
OSError: [Errno 95] Operation not supported

Unfortunately have no idea how to fix the problem

Systeminfo Bundle

octoprint-systeminfo-20211014171539.zip (15.8 KB)

The error you quoted also says it continued without and after there are some parts off a communication seen. Your printer then doesn't respond to an handshake attempt within 30s and OctoPrint gives up. I've seen this happen on my own MK3 occasionally, and usually when for whatever reason it takes ages to initialize right after reboot while scanning this files on the SD or is trying to connect to a non existent MMU.

To rule out the attempt to set low latency as the culprit, disable that under Settings > Serial > Connection.

deactivate latency… i can#t find this under Settings > Serial > Connection :frowning:

Apologies, didn't have the UI in front of me, Settings > Serial Connection > General

yes under general -> Request low latency mode on the serial port
but the problem remains

Gina mentioned disabling that option to see if it made a difference. Is that what you tried?

yes deactivated without any effect… only the latency error message in octoprint.log disappeared

On the printer's menu, do you have 'RPi Port' set to on? Make sure it is turned off.

Apparently (based on the number of confused people) it sometimes switches and the name is confusing.

Hi Charlie and thanks for your suggestion.
In fact, the pi port was turned on. With the setting off the communication to the printer works now too :slight_smile: :slight_smile:

1 Like

I have had a similar issue. My RPI was off, i then updatet my PI, it does seem to work for now.
In case anyone else does have similar issues

Yeah, I think there was a firmware update from Prusa at one point that would turn the on by default for some reason.