Octo Print Getting a Error:Probing Failed

What is the problem?

Hello, Let me start off by saying I'm new to 3D Printing. I got my First Printer about 10 days ago.
I have a Creality CR-10S Pro V2. I have Octo Pi installed on a Raspberry Pi 4 8g. Everything went fine. Octo print see's my printer. The printer works fine 100% of the time when I print or do something from the Printer it'self. Once I try to print through Octo Print Dash board the printer heats up the bed and then the Element to temperature settings and Fails with the Error: Probing Failed! I will include the terminal out put from this happening. Any Help would be great.

What did you already try to solve this?

I check You tube every where. Tried blocking power on the USB cable to the printer.

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

No had same result.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20221105002816.zip (669.7 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint Version: Version 1.8.6 OctoPi Version 0.18.0 Printer is a Creality CR-10S Pro V2
Firmware on printer is Ver 1.0.0 BL Browser is Chrome I'm using Windows 10 Pro as my OS on my pc.

It's the printer that reports the error but does not tell what exactly happened.
You may observe what happens during G29.

You also may have a look on this thread:

Thanks I read that thread you pointed me too. I'm not sure what firmwares will work with what machines. :frowning: I'm to new at this. I'm willing to try anything to fix it. But I will need someone to kind of walk me through how to do things so I don't end up bricking my printer. I am willing to even pay some one to help me get it working if needed. Maybe some one who has a CR-10S Pro V2 and has changed their firmware to some thing else to get things working.

Do you have a BLTouch or CRTouch probe on the printer or is it stock? If it doesn't have the probe, sending it a G29 will fail.
If you are slicing with Cura, make sure your start gcode under printer settings doesn't have a G29

And if you are using Octoprint, why are you still printing from the SD card?

It's the BLTouch that came stock with the CR-10S Pro V2. And I am using Cura to slice. Ok I will confirm what your telling me.

Because that the only way it will print right now, until I can get OctoPrint to quit error out.

I checked under my Cura Start code for this machine and it does have these codes in it.
G28 ;Home
G29 ; Auto bed Level
Are you saying I need to remove the G29 line of code? Do I need to replace it with some thing else for it to Auto bed Level?

Dont know whether this is the problem but I have the same printer and I was reading the other day that if the bed is physically out of true by too much then the auto levelling can't cope and you get probing error. From the printer get it to do a probe and look at the results from each probe point. If it's way off use the adjustment wheels to correct it. Also what happens i you get z sag on one side compared to the other . When you got the printer it will have come with an anonymous looking plastic rectangle. This is used the equalise the height on each side. Use the move function on the printer move z up . Stick the rectangle under the lhs and lower z until it touches, then move the rectangle to the rhs.manually turn the z screw by hand until it touches. Then recheck lhs. Once the z's are equal run the probe function again and alter the wheels to level it up. Make sure you don't move the whole bed up or you may find the hot end collides with the bed. I have printed a pair of z stays that I put under each side everything I switch the printer off to prevent sag.

Thanks for the tip, but leveling is not the issue at all. My bed has been leveled over and over along with the gantry. When it tries to probe through octoprint the probe never even touches the bed before it fails. I also printed myself 2 gantry leveling blocks for this printer. I really wish I could figure this out once and for all. But No luck so far. :frowning:

I can only guess that it's the g code command that others mentioned. I use the slicer that came with the printer and it doesn't do a bed probe at the beginning, although I have used the cura slicer once or twice and I think it did do a bed level successfully. I'm waiting for a new PC as my old one broke. I'll have an experiment once it arrives.

Wait you have same printer? CR-10S Pro V2? Because If that is the case I can use the same creality slicer that came with it to see if it works correctly.

Well I tried the Creality slicer that came with printer and had the same result: Probing Error
It does look like it's is the printer firmware throwing the error, as ewald_ikemann stated above. But I'm not sure how to fix it. If anyone has any advice or wisdom I would appreciate any help. I'm uploading the log from octoprint on tonights try to print from Octoprint. I guess I'll try updated firmware and LCD firmware.
octoprint.log (51.5 KB)

If you want to stop cura from sending the bed level see this software - How to configure Cura to run the Z probe before heating - 3D Printing Stack Exchange

I hope the firmware update goes OK.

I can't really help, but recently had the same problem on my Ender 5 with my version of the Euclid probe. I had made 2 successful prints and when I went to do the third one that day, Got the error. After several resets, re-sliced the model and has been working since. Don't have a clue what caused it or fixed it really. Also between failure and success again, I did a manual G29 and it worked.
I hope somebody comes up with a definite cause so we all can make the necessary corrections.

So it looks like it's all working now correctly. The only thing I did other then what's mentioned above is today I updated the creality Firmware and LCD screen firmware. I went right to the Creality Site and down loaded the latest version for both. After I did that and installed it. everything worked correctly. I also tested printing things using the Creality slicer and the latest version of Cura. Both worked with no issues. I did not change any Gcode whats so ever, I just left it at what ever the slicer put into the files. Thanks All