Octo4a - run OctoPrint on Android

Tried 4 different android devices, all of them do not install octo4a, always get installation corrupted. I guess this software is dead now. too bad, :frowning:

In the name of all open source maintainers, never make public declarations of a project being dead just because it doesn't work for you. Thank you.

2 Likes

For what it's worth, Filip is aware of the install issue with Octo4a and OctoPrint 1.8.3+, and we were talking about how best to solve it just the other day.

Hi,

The app keeps on saying that it is corrupted and i should re-install. has this issue been resolved?

Have you updated your app to the latest version? The install issues with 1.8.3+ were fixed a while ago. Unless you mean some other issue - I can't tell what you are referring to.

the app works for a while then stops and says that it must be reinstalled as it is corrupted? Samsung A12 / Samsung note 20 ultra same on both phones

I'm trying to instal this on my Oneplus N100 and am having the same issues, regardless of the version of Octo4a I choose... I so needed to make this work...

I've been trying to install the current version of this on an old Pixel 3 xl but it keeps coming up as corrupt. Is there something im missing?

Having the same problem as of today (1/1/2023) - tried on Asus Zenpad z8 and Samsung Tab 8. Both had the same issue - tried wiping both tablets and reinstalling/uninstalling multiple times.

Try the steps suggested in this link. This worked for me to get my Pixel 2xl working. Good luck!

I have no idea what all the ssh stuff is… I looked up how to do it with the windows command thing, but it kept saying that i doesn’t recognize the commands. Could you help me figure out what all of this is and/or point me where I can for myself?
I bought a refurbished pixel 2 xl if that helps

I tried to put the ssh port where the guys command says “PORT” to see if that was my problem, then this happened and I don’t know what it means

The command is
ssh root@IP -p PORT
where "IP" is the IP Address of your phone device and "PORT" is 8022
It should look something like this:
ssh root@192.168.1.100 -p 8022

Be sure to use the IP of your phone. The rest of the commands are typed pretty much as shown. Good luck!

1 Like

Thank you! That worked.
So I was able to do that step, but when I pasted “ pip3 install --upgrade setuptools wheel tornado --no-cache-dir “ this is what happened

Also, I can tell that step 6 may confuse me… do I just copy and paste, or do I copy what’s in the link? If I copy what’s in the link, is it saying to put “curl -s” before and “|bash -s” after the command?

Ps, when it had me to put in the password, I didn’t know it was invisible, so I thought I broke something if that tells you anything about my ignorance on this lol

I get this:
ssh: connect to host 192.168.0.124 port 8022: Connection timed out

That's September, so has anything happened since then? I tried to SSH into the phone as has been suggested with "ssh root@192.168.0.124 -p 8022", but I'm getting "Connection timed out".

This just seems to be the current state of the app. I've been able to get it to work on Android 10, but not Android 11. I get the same error you do. Looks like SSH gets shutdown on Octo4a, so you can't make the connection. I think there is something different with the security in Android 11 that's not allowing it to work. I'm not a programmer, just a consumer, so it's just my guess.

I got mine to work finally. Btw, I’m using a refurbished Pixel 2 XL.
Here are the step repeated but more detailed to make it easier for computer dumb people like me.
Copy and paste what is in the quotes (ie “ “) but not the quotes themselves

  1. Install Octo4A, let it install OctoPrint. Let the setup go, let it crash.

  2. Start the Octo4A, you can see it is corrupted, but dont reinstall !

2.5 I repeat do NOT hit reinstall, I think it kept it from working for me when I first tried this in December.. I deleted the app from my phone and reinstalled it from the site so I could start from scratch, but did NOT hit reinstall! Again, I did NOT click reinstall! Just let it crash, open the app, do the battery and cameras popups, and just go straight to doing the ssh stuff.

  1. Go to Config, enable OpenSSH and set Port and Password.

3.5 to do the commands for windows, you go to the search thing and type “Command Prompt” the picture looks like a little black screen with fake letters/writings on it, kinda like an old computer that you see in like 70s movies or whatever. It should be preinstalled, if not, Google how to install the windows command prompt. Open the application on your computer. That’s where you’ll put the commands. Make sure you remember what the command prompt says before you put any commands into. That will let you know when some of the nexts commands are finished. It should pop up each time a command is finished.

  1. Log into SSH from your computer or whatever. “ssh root@IP -p PORT”

4.5 now instead of “IP” go into your phone settings to find your IP address. And the ”PORT” should be replaced with the “8022” that’s shown in the octo4a app settings under ‘SSH port’ …for example, it should look something like “ssh root@123.456.789.12 -p 8022” the spaces are after your ip address and “-p” are important.
It will ask for the password that the octo4a app has you make. Type it into command prompt once. It will be invisible and it will give no indication a password is being typed, so typing it in several types wont work and it would tell you that the password is incorrect. If that happens, just type only once it in when asked, and it should work. Took me a while to figure that out lol

  1. Now enter command, always wait for finish:
    “pip3 install --upgrade setuptools wheel tornado --no-cache-dir*”

5.5 it takes a bit… you’ll know when it’s done when it gives you that command prompt again… same with all of the next commands… I think the next ones all have a download, could be wrong, if not, it’ll still give you the command prompt mentioned at step 3.5

  1. I am not sure with the next command, it is probably not needed, but i put it in:
    “curl -s https://raw.githubusercontent.com/feelfreelinux/octo4a/master/scripts/setup-octo4a.sh | bash -s*”

7.5 I did it… haven’t tested the app with my printer yet, so if it doesn’t work with the printers, I would try deleting the app and staying over but skipping step 7… have no idea if that would be a good… again, haven’t tested the app yet, but it appears to be running octoprint properly

  1. Then enter this, once asked, overwrite all files:
    “unzip octoprint.zip*”

9.5 don’t type “yes” because it would take FOREVER. I tried typing “all” but it didn’t work for me… until I noticed that it’s supposed to have a capital letter like “All”…. That worked for me… I just wasted time typing “yes” for a few minutes.

  1. And finally this command (ALSO COPY THE DOT):
    “cd Octo* && pip3 install .*”

  2. I also installed plugin extras from the setting menu

13.5 it’s in the setting menus in the octo4a app at top. Just click it. after finished all the steps, I noticed that it wasn’t installed I just clicked it again. Didn’t seem to mess anything up so far

  1. Now Force stop the app somehow (I needed to go to app setting and force stop on my Huaweii P20 Pro, I did similar on Redmi Note 4)

14.5 for my Pixel 2 XL, I went to my phone settings, Apps & notifications, OctoPrint For Android, then I hit the force stop button. Finally I just opened the app… can’t remember if it automatically reinstalled octoprint or if it still said that it was corrupted and I had to hit reinstall… if the latter, then only hit reinstall AFTER doing all of the previous steps.

  1. Turn on the Octo4A, and it should work !

Hope this works for everyone else!

Did those clarifying steps I just
made above work for you?

These steps are basically what you can find here:

Use the github comments - made it work on my Amazon Fire Tablet from 2015.