Octodash touch function not working newest octopi update

What is the problem?

Touchscreen not working for octodash after newest octoprint update. I just bought a BTT tft50 v2.0 screen for my pi that came in a bundle with my new octopus board. I haven't yet setup the printer because I am trying to conquer this hurdle first. If I install rasberry pi os (32bit) my touch functionality works fine. But if I do a clean image of octopi (latest version) and install octodash I get to the "Hey there" welcome screen in octodash but my touch function does not work. I can't press next. If I am doing something wrong please let me know but I have a feeling it's an issue with the newest version of octopi as my touch works on all other os's. It seems like octopi disables something in the back end and the touch stops working. If anyone knows of a fix or a command to type into ssh I would greatly apreciate it. I am very new to all this ssh stuff and commands etc but I learn quick and I am pretty good with computers etc. Also I have tried sudo apt-get install and upgrade etc. didn't help.

What did you already try to solve it?

I tried fresh install of everything, raspberry pi os with all updates works fine but if I install a fresh image of octopi on my pi and install octodash my touch stops working.

Have you tried running in safe mode?

Not sure how to

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 3970772992
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.1
env.plugins.pi_support.octopi_version: 1.0.0
env.plugins.pi_support.octopiuptodate_build: 1.0.0-1.9.1-20230627080047
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 22.3
env.python.version: 3.9.2
env.python.virtualenv: True
octoprint.last_safe_mode.date: unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.9.1
systeminfo.generated: 2023-07-08T11:29:27Z
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible
octopi, newest version available, printer will be a ender 3 pro with octopus v1, chrome,win 11.

Hello @FatCatMedia_FCM !

Blue words are links.

Please provide the systeminfo bundle.

Thank you.

The link you sent shows how to start octpi in safe mode, how do I start octodash in safe mode? Octopi in safe mode made no changes.

It has to be something to do with the new version of octopi and it disabling a service or something to stop the touch function working. Is there a way to see what services and drivers are running and a way to turn on any service/driver that is disabled?

No, it shows how to start OctoPrint in safe mode.

I don't think there is a save mode for OctoDash.

Also you can get more info here:

issue fixed. Turns out is has to do with dtoverlay. BTT pi TFT50 Touch Screen not working... · Issue #3707 · UnchartedBull/OctoDash · GitHub is a link to github where I explain how to fix it.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.