Octopi does not see printer (but PC does)

What is the problem?

I had Octopi running on my RP4 2GB with my Ender 3 Pro for months without issue. Two days ago, I disconnected the USB cable and unplugged the power of the RPi. I plugged everything back in and OctoPrint no longer recognizes my printer. I get the error message:

Offline (Error: No more candidates to test, and no working port/baudrate combination detected.)

And the only option under Serial Port is "Auto". Suspecting Octopi was not seeing the printer at all, I SSH in and ran lsusb:


And I was correct, the Pi does not see the printer at all. I connected my Win10 laptop to the printer (after installing drivers) and Cura was able to see and control the printer. All using the same USB cable.

What did you already try to solve it?

  • Reinstalled Octopi .17, .16, and now on .18
  • Used a RPi 4 4GB
  • Multiple ports and multiple USB cables
  • Taped the power pin(5?) of the USB cable
  • Plugged in other usb devices into the RPi, ran lsusb and the other devices DO show up.
  • Multiple combinations of plugging in RPi / power off or on the Ender etc

Additional information about your setup

Octopi .17 Octoprint 1.4 Raspberry Pi 4 2GB

Update on my testing:

Test 1

  • Power off on Ender
  • Plugged into PC
  • Ender is detected

Test 2

  • Ender powered on
  • Plug into PC
  • Ender is not detected

Test 3

  • Ender power off
  • Plug into PC
  • Ender is detected
  • Unplug, wait, plug back in
  • Ender is not detected

Hello @wh1skey6!

Do you have the chance to test with another RasPi?

Is "PC" here the Pi or your laptop? Because if your laptop intermittently also doesn't see the printer, I'd suggest that the fault lies with the printer controller, not the Pi.

Yes, I tested with another RPi 4 4gb. Same results.

PC is my Win10 laptop. My first thought was indeed a bad port or board so I did the test series. My results show that for PC to see the Ender, it needs to be powered off when I plug in the USB. Then power it on and Cura will see it. If I power the Ender on first then plug in the USB, the PC does not recognize the Ender. Test 1 has repeatable results.

Hello, have you solved your problem and if so how? I have the exact same problem, octoprint no longer wants to connect to my printer and gives me the same error message. On the other hand, I can connect with my laptop to the printer via the "repetier" software. Thank you for your reply...

Not yet but I'll try again today. I left the Ender unplugged all weekend in case it was an issue with the board or some capacitor related issue.

After pulling out three different USB C power adapters and 5 mini USB cords, I went down the arduous task of testing every combination of power adapter and cord. I found one combination of power adapter and cord that actually work...and it wasn't even the one that worked before. I got my answer on Reddit by someone who pointed out RPi 4 can be very finicky in power and USB.